FAQ
I've encountered a strange problem in CentOS 4.1. I've never had this
problem before, and I've been using X Windows since 1990, but I can't
get remote X connections to work:

$ hostname
host00
$ echo $DISPLAY
:0.0
$ xhost +
access control disabled, clients can connect from any host
$ rsh host01
$ xdpyinfo -d host00:0.0
xdpyinfo: unable to open display "host00:0.0"

Both hosts are running CentOS 4.1 and SELinux is disabled. I know I
can get this to wok with ssh, but that is not the point. Also, it's
not a host name resolution problem, as substituting the IP address in
the above command gives the same error. Finally, note that there is
about a 3-4 second delay before the error message appears.

Any recent changes in X that I am unaware of?

Alfred

Search Discussions

  • James Pearson at Oct 18, 2005 at 10:36 am

    Alfred von Campe wrote:
    I've encountered a strange problem in CentOS 4.1. I've never had this
    problem before, and I've been using X Windows since 1990, but I can't
    get remote X connections to work:

    $ hostname
    host00
    $ echo $DISPLAY
    :0.0
    $ xhost +
    access control disabled, clients can connect from any host
    $ rsh host01
    $ xdpyinfo -d host00:0.0
    xdpyinfo: unable to open display "host00:0.0"

    Both hosts are running CentOS 4.1 and SELinux is disabled. I know I can
    get this to wok with ssh, but that is not the point. Also, it's not a
    host name resolution problem, as substituting the IP address in the
    above command gives the same error. Finally, note that there is about a
    3-4 second delay before the error message appears.
    If you are using gdm - try setting:

    DisallowTCP=false

    in /etc/X11/gdm/gdm.conf

    James Pearson
  • Alfred von Campe at Oct 18, 2005 at 11:32 am

    On Oct 18, 2005, at 11:36, James Pearson wrote:

    If you are using gdm - try setting:

    DisallowTCP=false

    in /etc/X11/gdm/gdm.conf
    How do I know if I'm using gdm (is it enabled by default)? In any
    event, changing that conf file and restarting the X server did not
    solve the problem.

    Alfred
  • James Pearson at Oct 18, 2005 at 3:08 pm

    Alfred von Campe wrote:
    On Oct 18, 2005, at 11:36, James Pearson wrote:

    If you are using gdm - try setting:

    DisallowTCP=false

    in /etc/X11/gdm/gdm.conf
    How do I know if I'm using gdm (is it enabled by default)? In any
    event, changing that conf file and restarting the X server did not solve
    the problem.
    Restarting X doesn't (necessarily) restart gdm

    You probably have to restart gdm ...

    James Pearson
  • Alfred von Campe at Oct 18, 2005 at 3:34 pm

    On Oct 18, 2005, at 16:08, James Pearson wrote:

    Restarting X doesn't (necessarily) restart gdm

    You probably have to restart gdm ...
    I'll try that again tomorrow (I've just left the classroom where this
    is the issue). I'll report back my findings then...

    Thanks,
    Alfred
  • Alfred von Campe at Oct 19, 2005 at 8:40 am

    Restarting X doesn't (necessarily) restart gdm

    You probably have to restart gdm ...
    Yup, that did the trick. Setting "DisallowTCP=false" in
    /etc/gdm/gdm.conf and then restarting gdm (killall -HUP gdm-binary)
    let's me have remote X connections again without having to use ssh.

    Thanks,
    Alfred

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedOct 18, '05 at 8:59a
activeOct 19, '05 at 8:40a
posts6
users2
websitecentos.org
irc#centos

2 users in discussion

Alfred von Campe: 4 posts James Pearson: 2 posts

People

Translate

site design / logo © 2022 Grokbase