FAQ
Hi list,
I have the choice to use RHEL4 or Centos4.x on a Dell PowerEdge2850 who
is linked to an AX100 storage system. My question is: does the QLA200
(the pci fiber channel card) driver will work on CentOS 4.1 . For now
the card is listed like this on CentOS 4.1:
---
#lspci
09:04.0 Fibre Channel: QLogic Corp.: Unknown device 6312 (rev 03)
---
What kind of modification must/can I do to the original RPM driver for
it to work on CentOS? Am I stuck to use RHEL?
Thanks for any advice.

Search Discussions

  • Johnny Hughes at Oct 10, 2005 at 12:02 pm

    On Mon, 2005-10-10 at 13:59 +0200, kadafax wrote:
    Hi list,
    I have the choice to use RHEL4 or Centos4.x on a Dell PowerEdge2850 who
    is linked to an AX100 storage system. My question is: does the QLA200
    (the pci fiber channel card) driver will work on CentOS 4.1 . For now
    the card is listed like this on CentOS 4.1:
    ---
    #lspci
    09:04.0 Fibre Channel: QLogic Corp.: Unknown device 6312 (rev 03)
    ---
    What kind of modification must/can I do to the original RPM driver for
    it to work on CentOS? Am I stuck to use RHEL?
    Thanks for any advice.

    _______________________________________________
    The driver should work on both CentOS and RHEL ... was it written for a
    specific kernel?
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: This is a digitally signed message part
    Url : http://lists.centos.org/pipermail/centos/attachments/20051010/18db361b/attachment.bin
  • Kadafax at Oct 10, 2005 at 12:19 pm

    Johnny Hughes wrote:

    The driver should work on both CentOS and RHEL ... was it written for a
    specific kernel?
    ---
    # pwd
    /mnt/cdrom/files/common/files/linux
    # rpm -Uvh qla2x00-v7.00.01-3.i686.rpm
    Preparing... ###########################################
    [100%]
    error: %pre(qla2x00-v7.00.01-3.i686) scriptlet failed, exit status 255
    error: install: %pre scriptlet failed (2), skipping qla2x00-v7.00.01-3
    ---

    ok I am on a X86-64 arch, this may explain the above behavior ?
  • Johnny Hughes at Oct 10, 2005 at 12:22 pm

    On Mon, 2005-10-10 at 14:19 +0200, kadafax wrote:
    Johnny Hughes wrote:

    The driver should work on both CentOS and RHEL ... was it written for a
    specific kernel?
    ---
    # pwd
    /mnt/cdrom/files/common/files/linux
    # rpm -Uvh qla2x00-v7.00.01-3.i686.rpm
    Preparing... ###########################################
    [100%]
    error: %pre(qla2x00-v7.00.01-3.i686) scriptlet failed, exit status 255
    error: install: %pre scriptlet failed (2), skipping qla2x00-v7.00.01-3
    ---

    ok I am on a X86-64 arch, this may explain the above behavior ?
    If you installed the x86_64 arch ... Yes, it looks like that RPM was
    written for an i686 kernel.

    Where did you get the RPM? Do that have a SRPM? Do they have an RPM
    for x86_64.
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: This is a digitally signed message part
    Url : http://lists.centos.org/pipermail/centos/attachments/20051010/70ed5a08/attachment.bin
  • Kadafax at Oct 10, 2005 at 12:58 pm

    Johnny Hughes wrote:
    If you installed the x86_64 arch ... Yes, it looks like that RPM was
    written for an i686 kernel.

    Where did you get the RPM? Do that have a SRPM? Do they have an RPM
    for x86_64.
    From the CD shipped with the card (by Dell, it was an all in one:
    PE-2850 & QLA-200HBA & EMC AX-100). There is no source on the CD nor
    X86-64 version. I can't find any driver for the QLA-200 on
    support.qlogic.com, except the windows one... I keep searching.
    ------------------------------------------------------------------------

    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Kadafax at Oct 10, 2005 at 1:51 pm
    I found drivers who seems to be arch independent at
    http://qlogic.com/support/oem_product_detail.asp?p_idh0&oemid(4&oemname=QLA200

    but, I've got the same error:
    ---
    # ./qlinstall

    #*********************************************************#
    # QLogic HBA Linux Driver Installation #
    # Version: 1.00.00b2pre16 #
    #*********************************************************#

    Kernel version: 2.6.9-11.ELsmp
    Distribution: CentOS release 4.1 (Final)

    Found QLogic Fibre Channel Adapter in the system
    1: QLA6312
    Installation will begin for following driver(s)
    1: qla2xxx version: v8.00.03b

    Preparing...
    ##################################################
    error: %pre(qla2xxx-v8.00.03b-1.noarch) scriptlet failed, exit status 255
    error: install: %pre scriptlet failed (2), skipping qla2xxx-v8.00.03b-1
    ---
    Do you know what is this "scriptlet" error?
    thanks
    Johnny Hughes wrote:
    If you installed the x86_64 arch ... Yes, it looks like that RPM was
    written for an i686 kernel.

    Where did you get the RPM? Do that have a SRPM? Do they have an RPM
    for x86_64.
    From the CD shipped with the card (by Dell, it was an all in one:
    PE-2850 & QLA-200HBA & EMC AX-100). There is no source on the CD nor
    X86-64 version. I can't find any driver for the QLA-200 on
    support.qlogic.com, except the windows one... I keep searching.
    ------------------------------------------------------------------------

    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
  • Johnny Hughes at Oct 10, 2005 at 2:37 pm

    On Mon, 2005-10-10 at 15:51 +0200, kadafax wrote:
    I found drivers who seems to be arch independent at
    http://qlogic.com/support/oem_product_detail.asp?p_idh0&oemid(4&oemname=QLA200

    but, I've got the same error:
    ---
    # ./qlinstall

    #*********************************************************#
    # QLogic HBA Linux Driver Installation #
    # Version: 1.00.00b2pre16 #
    #*********************************************************#

    Kernel version: 2.6.9-11.ELsmp
    Distribution: CentOS release 4.1 (Final)

    Found QLogic Fibre Channel Adapter in the system
    1: QLA6312
    Installation will begin for following driver(s)
    1: qla2xxx version: v8.00.03b

    Preparing...
    ##################################################
    error: %pre(qla2xxx-v8.00.03b-1.noarch) scriptlet failed, exit status 255
    error: install: %pre scriptlet failed (2), skipping qla2xxx-v8.00.03b-1
    ---
    Do you know what is this "scriptlet" error?
    thanks
    Johnny Hughes wrote:
    If you installed the x86_64 arch ... Yes, it looks like that RPM was
    written for an i686 kernel.

    Where did you get the RPM? Do that have a SRPM? Do they have an RPM
    for x86_64.
    From the CD shipped with the card (by Dell, it was an all in one:
    PE-2850 & QLA-200HBA & EMC AX-100). There is no source on the CD nor
    X86-64 version. I can't find any driver for the QLA-200 on
    support.qlogic.com, except the windows one... I keep searching.
    I can't really tell without the source code.

    You might try installing i386 distro ... also, before that you might see
    if changing the text in /etc/redhat-release to what it says for the
    upstream vendor will make it work.
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: This is a digitally signed message part
    Url : http://lists.centos.org/pipermail/centos/attachments/20051010/75a362ec/attachment.bin
  • Kadafax at Oct 10, 2005 at 3:41 pm
    I respond to myself, in case it may help someone with the same hardware:
    the good drivers (at least the rpm's output says that everything is ok)
    are the dkms's one:
    http://download.qlogic.com/drivers/32113/qla2xxx-v8.00.03b-1dkms.tar.gz
    ---
    # rpm -Uvh dkms-2.0.5-1.noarch.rpm
    # rpm -Uvh qla2xxx-v8.00.03b-1dkms.noarch.rpm

    It need the kernel devel package in order to build the module.
    [OFF] It seems that my Selinux was the source of the scriplet error.
    Btw lspci output still shows:
    09:04.0 Fibre Channel: QLogic Corp.: Unknown device 6312 (rev 03)

    Thanks anyway and if someone use the same hardware on CentOS I would
    really appreciate some hints for a clean install.
    kadafax

    kadafax wrote:
    I found drivers who seems to be arch independent at
    http://qlogic.com/support/oem_product_detail.asp?p_idh0&oemid(4&oemname=QLA200


    but, I've got the same error:
    ---
    # ./qlinstall

    #*********************************************************#
    # QLogic HBA Linux Driver Installation #
    # Version: 1.00.00b2pre16 #
    #*********************************************************#

    Kernel version: 2.6.9-11.ELsmp
    Distribution: CentOS release 4.1 (Final)

    Found QLogic Fibre Channel Adapter in the system
    1: QLA6312
    Installation will begin for following driver(s)
    1: qla2xxx version: v8.00.03b

    Preparing...
    ##################################################
    error: %pre(qla2xxx-v8.00.03b-1.noarch) scriptlet failed, exit status 255
    error: install: %pre scriptlet failed (2), skipping qla2xxx-v8.00.03b-1
    ---
    Do you know what is this "scriptlet" error?
    thanks
    Johnny Hughes wrote:
    If you installed the x86_64 arch ... Yes, it looks like that RPM was
    written for an i686 kernel.

    Where did you get the RPM? Do that have a SRPM? Do they have an RPM
    for x86_64.
    From the CD shipped with the card (by Dell, it was an all in one:
    PE-2850 & QLA-200HBA & EMC AX-100). There is no source on the CD nor
    X86-64 version. I can't find any driver for the QLA-200 on
    support.qlogic.com, except the windows one... I keep searching.
    ------------------------------------------------------------------------


    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos
    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedOct 10, '05 at 11:59a
activeOct 10, '05 at 3:41p
posts8
users2
websitecentos.org
irc#centos

2 users in discussion

Kadafax: 5 posts Johnny Hughes: 3 posts

People

Translate

site design / logo © 2022 Grokbase