FAQ
This ntp.conf file works fine under RedHat 9:

authenticate no
#enable auth
driftfile /etc/ntp/drift
keys /etc/ntp/ntp.keys
server 127.127.1.0
fudge 127.127.1.0 stratum 10
trustedkey 1
enable bclient
broadcastclient

However, it doesn't work on CentOS 4.1. ntpd complains with this error message:

Unable to listen for broadcasts, no broadcast interfaces available

Has anyone gotten ntp broadcastclient to work under CentOS? This is
very similar to the problem explained by this email thread:

http://lists.freebsd.org/pipermail/freebsd-questions/2004-August/057010.html

Any help is appreciated.

Search Discussions

  • Peter Kjellström at Oct 4, 2005 at 11:25 am
    Hello,

    While I don't know what's wrong with your specific ntp.conf I do have one for
    Centos-4.1.x86_64 that works with broadcastclient:

    driftfile /etc/ntp/drift
    disable auth
    broadcastclient

    Cheers,
    Peter
    On Tuesday 04 October 2005 03.11, Fong Vang wrote:
    This ntp.conf file works fine under RedHat 9:

    authenticate no
    #enable auth
    driftfile /etc/ntp/drift
    keys /etc/ntp/ntp.keys
    server 127.127.1.0
    fudge 127.127.1.0 stratum 10
    trustedkey 1
    enable bclient
    broadcastclient

    However, it doesn't work on CentOS 4.1. ntpd complains with this error
    message:

    Unable to listen for broadcasts, no broadcast interfaces available

    Has anyone gotten ntp broadcastclient to work under CentOS? This is
    very similar to the problem explained by this email thread:


    http://lists.freebsd.org/pipermail/freebsd-questions/2004-August/057010.htm
    l

    Any help is appreciated.
    --
    ------------------------------------------------------------
    Peter Kjellstr?m |
    National Supercomputer Centre |
    Sweden | http://www.nsc.liu.se
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: not available
    Url : http://lists.centos.org/pipermail/centos/attachments/20051004/41ca414c/attachment.bin
  • Fong Vang at Oct 4, 2005 at 7:17 pm
    This works. It needed the "disable auth" line. Thanks.
    On 10/4/05, Peter Kjellstr?m wrote:
    Hello,

    While I don't know what's wrong with your specific ntp.conf I do have one for
    Centos-4.1.x86_64 that works with broadcastclient:

    driftfile /etc/ntp/drift
    disable auth
    broadcastclient

    Cheers,
    Peter
    On Tuesday 04 October 2005 03.11, Fong Vang wrote:
    This ntp.conf file works fine under RedHat 9:

    authenticate no
    #enable auth
    driftfile /etc/ntp/drift
    keys /etc/ntp/ntp.keys
    server 127.127.1.0
    fudge 127.127.1.0 stratum 10
    trustedkey 1
    enable bclient
    broadcastclient

    However, it doesn't work on CentOS 4.1. ntpd complains with this error
    message:

    Unable to listen for broadcasts, no broadcast interfaces available

    Has anyone gotten ntp broadcastclient to work under CentOS? This is
    very similar to the problem explained by this email thread:


    http://lists.freebsd.org/pipermail/freebsd-questions/2004-August/057010.htm
    l

    Any help is appreciated.
    --
    ------------------------------------------------------------
    Peter Kjellstr?m |
    National Supercomputer Centre |
    Sweden | http://www.nsc.liu.se


    _______________________________________________
    CentOS mailing list
    CentOS@centos.org
    http://lists.centos.org/mailman/listinfo/centos


Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedOct 4, '05 at 1:11a
activeOct 4, '05 at 7:17p
posts3
users2
websitecentos.org
irc#centos

2 users in discussion

Fong Vang: 2 posts Peter Kjellström: 1 post

People

Translate

site design / logo © 2021 Grokbase