FAQ
hi all,

I am using centos3.5 for my firewall home. I would like to do some
tests with bridge firewalling. When i try to create the bridge, brctl
givtes me this error: br_add_bridge: Package not installed.

i find some answers about this error, but the most important is the
one that says driver is not loaded into kernel. In my
/boot/config-2.4.21-32.0.1.EL file appears compiled as a module, but how
can i load it with modprobe?? .... :((

Thanky you
--
CL Martinez
carlopmart {at} gmail {d0t} com

Search Discussions

  • Oliver Falk at Sep 13, 2005 at 7:34 am

    On 09/12/2005 10:54 PM, carlopmart@gmail.com wrote:
    hi all,

    I am using centos3.5 for my firewall home. I would like to do some
    tests with bridge firewalling. When i try to create the bridge, brctl
    givtes me this error: br_add_bridge: Package not installed.

    i find some answers about this error, but the most important is the one
    that says driver is not loaded into kernel. In my
    /boot/config-2.4.21-32.0.1.EL file appears compiled as a module, but how
    can i load it with modprobe?? .... :((

    Thanky you
    I guess, that brctl will not load the module automatically and your
    system doesn't either...

    Try it this way:

    [root@pluto ~]# modprobe bridge; lsmod | grep bridge
    bridge 52953 0

    It's a FC4 in my case, but this should work with CentOS also...

    Best,
    Oliver
  • Carlopmart at Sep 13, 2005 at 2:02 pm
    In kernel 2.4 bridge module doesn't exists ....wih this name ..



    Oliver Falk wrote:
    On 09/12/2005 10:54 PM, carlopmart@gmail.com wrote:

    hi all,

    I am using centos3.5 for my firewall home. I would like to do some
    tests with bridge firewalling. When i try to create the bridge, brctl
    givtes me this error: br_add_bridge: Package not installed.

    i find some answers about this error, but the most important is the
    one that says driver is not loaded into kernel. In my
    /boot/config-2.4.21-32.0.1.EL file appears compiled as a module, but
    how can i load it with modprobe?? .... :((

    Thanky you

    I guess, that brctl will not load the module automatically and your
    system doesn't either...

    Try it this way:

    [root@pluto ~]# modprobe bridge; lsmod | grep bridge
    bridge 52953 0

    It's a FC4 in my case, but this should work with CentOS also...

    Best,
    Oliver
    --
    CL Martinez
    carlopmart {at} gmail {d0t} com
  • Tru Huynh at Sep 13, 2005 at 2:26 pm

    On Tue, Sep 13, 2005 at 04:02:46PM +0200, carlopmart@gmail.com wrote:
    In kernel 2.4 bridge module doesn't exists ....wih this name ..
    it does exist, you need to install the kernel-unsupported
    or kernel-smp-unsupported package

    /lib/modules/2.4.21-32.0.1.EL/unsupported/net/bridge/bridge.o
    /lib/modules/2.4.21-32.0.1.ELsmp/unsupported/net/bridge/bridge.o

    Tru
    --
    Tru Huynh (CentOS-3 i386/x86_64 Package Maintenance)
    http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xBEFA581B
    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: not available
    Type: application/pgp-signature
    Size: 189 bytes
    Desc: not available
    Url : http://lists.centos.org/pipermail/centos/attachments/20050913/02dd8cb6/attachment.bin

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos @
categoriescentos
postedSep 12, '05 at 8:54p
activeSep 13, '05 at 2:26p
posts4
users3
websitecentos.org
irc#centos

People

Translate

site design / logo © 2021 Grokbase