FAQ
All,

I've spent quite a few hours trying to figure this out to no avail... I
have two machines and the result is the same on both. Additionally,
each machine does not support full hardware virtualization...

I am able to create 8 VMs. When attempting to create ninth VM, I get the following
error:

Error: Device 51712 (vbd) could not be connected. /etc/xen/scripts/block
failed; error detected.

To create the VMs, I use the command:

"xm create [vm name]"

My machine has 8 GB RAM and is an "old school" dual opteron box.

"uname -a" is:

Linux centos-host-2 2.6.18-274.3.1.el5.centos.plusxen #1 SMP Wed Sep 7
06:25:54 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux


To be clear, I can shutdown any one of the 8 VMs and then run the ninth
"xm create" - that VM will start...

I did some google'ing and from what I cn tell that error arises due to the
lack of loop back devices (there being 8 by default)...

I've tried both using MAKEDEV (in my /etc/rc.local) to create a number of
loop back devices and put max_loops in my grub,.conf file. For example
here is what I have in grub.conf now:

title CentOS (2.6.18-274.3.1.el5.centos.plusxen)
root (hd0,0)
kernel /xen.gz-2.6.18-274.3.1.el5.centos.plus
module /vmlinuz-2.6.18-274.3.1.el5.centos.plusxen ro root=LABEL=/
max_loopd
module /initrd-2.6.18-274.3.1.el5.centos.plusxen.img


Due to wrapping, max_loop is actually on the module /vmlinuz- line...

I also tried to put max_loop on the kernel line as well...

As I mentioned above, I also created the loop back devices from
/etc/rc.local like so:

/sbin/MAKEDEV -d /dev -m 64 loop

And, once I can log in to the machine, I do see everything in /dev (for
example /dev/loop0 to /dev/loop64)

Has anyone else had this problem? If so, how did you resolve it????


Thanks ahead of time!!!!!


Scot P. Floess RHCT (Certificate Number 605010084735240)
Chief Architect FlossWare http://sourceforge.net/projects/flossware
http://flossware.sourceforge.net
https://github.com/organizations/FlossWare

Search Discussions

  • Ian Forde at Sep 19, 2011 at 3:07 am

    On Sep 18, 2011, at 9:13, "Scot P. Floess" wrote:

    I did some google'ing and from what I cn tell that error arises due to the
    lack of loop back devices (there being 8 by default)...

    I've tried both using MAKEDEV (in my /etc/rc.local) to create a number of
    loop back devices and put max_loops in my grub,.conf file. For example
    here is what I have in grub.conf now:

    title CentOS (2.6.18-274.3.1.el5.centos.plusxen)
    root (hd0,0)
    kernel /xen.gz-2.6.18-274.3.1.el5.centos.plus
    module /vmlinuz-2.6.18-274.3.1.el5.centos.plusxen ro root=LABEL=/
    max_loopd
    module /initrd-2.6.18-274.3.1.el5.centos.plusxen.img


    Due to wrapping, max_loop is actually on the module /vmlinuz- line...

    I also tried to put max_loop on the kernel line as well...

    As I mentioned above, I also created the loop back devices from
    /etc/rc.local like so:

    /sbin/MAKEDEV -d /dev -m 64 loop

    And, once I can log in to the machine, I do see everything in /dev (for
    example /dev/loop0 to /dev/loop64)

    Has anyone else had this problem? If so, how did you resolve it????
    Actually, you have max_loopsd in the wrong file. You want it in /etc/modprobe.conf as thus:

    options loop max_loopd

    Once that is in, a reboot (after shutting down the running VMs) is the quickest way to activate it. Take the makedev and grub stuff out...

    -I
  • Scot P. Floess at Sep 19, 2011 at 8:47 am
    Ian,

    Hey thanks! I'll definitely try that...


    On Mon, 19 Sep 2011, Ian Forde wrote:
    On Sep 18, 2011, at 9:13, "Scot P. Floess" wrote:

    I did some google'ing and from what I cn tell that error arises due to the
    lack of loop back devices (there being 8 by default)...

    I've tried both using MAKEDEV (in my /etc/rc.local) to create a number of
    loop back devices and put max_loops in my grub,.conf file. For example
    here is what I have in grub.conf now:

    title CentOS (2.6.18-274.3.1.el5.centos.plusxen)
    root (hd0,0)
    kernel /xen.gz-2.6.18-274.3.1.el5.centos.plus
    module /vmlinuz-2.6.18-274.3.1.el5.centos.plusxen ro root=LABEL=/
    max_loopd
    module /initrd-2.6.18-274.3.1.el5.centos.plusxen.img


    Due to wrapping, max_loop is actually on the module /vmlinuz- line...

    I also tried to put max_loop on the kernel line as well...

    As I mentioned above, I also created the loop back devices from
    /etc/rc.local like so:

    /sbin/MAKEDEV -d /dev -m 64 loop

    And, once I can log in to the machine, I do see everything in /dev (for
    example /dev/loop0 to /dev/loop64)

    Has anyone else had this problem? If so, how did you resolve it????
    Actually, you have max_loopsd in the wrong file. You want it in /etc/modprobe.conf as thus:

    options loop max_loopd

    Once that is in, a reboot (after shutting down the running VMs) is the quickest way to activate it. Take the makedev and grub stuff out...

    -I
    _______________________________________________
    CentOS-virt mailing list
    CentOS-virt at centos.org
    http://lists.centos.org/mailman/listinfo/centos-virt
    Scot P. Floess RHCT (Certificate Number 605010084735240)
    Chief Architect FlossWare http://sourceforge.net/projects/flossware
    http://flossware.sourceforge.net
    https://github.com/organizations/FlossWare
  • Scot P. Floess at Sep 19, 2011 at 1:21 pm
    Ian,

    That did it! Thanks so much... I've got 12 VMs running now...just fine
    :)
    On Mon, 19 Sep 2011, Ian Forde wrote:
    On Sep 18, 2011, at 9:13, "Scot P. Floess" wrote:

    I did some google'ing and from what I cn tell that error arises due to the
    lack of loop back devices (there being 8 by default)...

    I've tried both using MAKEDEV (in my /etc/rc.local) to create a number of
    loop back devices and put max_loops in my grub,.conf file. For example
    here is what I have in grub.conf now:

    title CentOS (2.6.18-274.3.1.el5.centos.plusxen)
    root (hd0,0)
    kernel /xen.gz-2.6.18-274.3.1.el5.centos.plus
    module /vmlinuz-2.6.18-274.3.1.el5.centos.plusxen ro root=LABEL=/
    max_loopd
    module /initrd-2.6.18-274.3.1.el5.centos.plusxen.img


    Due to wrapping, max_loop is actually on the module /vmlinuz- line...

    I also tried to put max_loop on the kernel line as well...

    As I mentioned above, I also created the loop back devices from
    /etc/rc.local like so:

    /sbin/MAKEDEV -d /dev -m 64 loop

    And, once I can log in to the machine, I do see everything in /dev (for
    example /dev/loop0 to /dev/loop64)

    Has anyone else had this problem? If so, how did you resolve it????
    Actually, you have max_loopsd in the wrong file. You want it in /etc/modprobe.conf as thus:

    options loop max_loopd

    Once that is in, a reboot (after shutting down the running VMs) is the quickest way to activate it. Take the makedev and grub stuff out...

    -I
    _______________________________________________
    CentOS-virt mailing list
    CentOS-virt at centos.org
    http://lists.centos.org/mailman/listinfo/centos-virt
    Scot P. Floess RHCT (Certificate Number 605010084735240)
    Chief Architect FlossWare http://sourceforge.net/projects/flossware
    http://flossware.sourceforge.net
    https://github.com/organizations/FlossWare

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos-virt @
categoriescentos
postedSep 18, '11 at 12:13p
activeSep 19, '11 at 1:21p
posts4
users2
websitecentos.org
irc#centos

2 users in discussion

Scot P. Floess: 3 posts Ian Forde: 1 post

People

Translate

site design / logo © 2022 Grokbase