FAQ
Hi - I have a machine which was originally built with Centos 5.0
including xen. It has all the current updates and here are some questions:

The current problem is:
1) If I boot the non-xen kernel - it runs fine. If I boot the xen kernel
- it boots - but has no network connectivity - and I get the following
errors continuously in the messages log:
Time/date: C5 Kernel: vif0.0: received packet with own address as source
address.

And another question:
2) The Centos 5.1 release notes say that the 5.1 xen release includes
dnsmasq, and that this may conflict with dhcpd and named if you are
running these. I am running both - and i thought dnsmasq was not running
because it is set to "not start at boot" - but I now notice that it is
"running" even though it is set to "not start on boot". This is true
whether I boot the xen or non-xen kernel. Is this a problem - and if so
- how do I stop it from running? How do dnsmasq and dhcpd both function
without breaking each other?

Now some detailed background:
The machine uses a Realtek 8111B network adaptor - and this has been a
problem all along. I used to manually reinstall the r1000 driver
(apparently the correct driver for the adaptor) every time the kernel
was updated. Tedious - but it worked. My xen kernel worked fine. Some
months back - a bunch of updates came through corresponding to the
release of Centos 5.1 - and my normal driver re-install didn't seem to
get the Xen kernel running. On advice from the Centos forums - I
installed the dkms-r1000 driver - and eventually got the non-xen kernel
running fine - but couldn't get the xen kernel running. Every boot - the
message "starting eth0 - Failed" would come up. I have been using the
non-xen kernel ever since. My system has both kernel-devel and
kernel-xen- devel installed.

Just yesterday - I installed the latest Kernels ( kernel
2.6.18-53.1.6.el5
<https://192.168.0.201:10000/software/edit_pack.cgi?search=kernel&package=kernel&version=2%2E6%2E18%2D53%2E1%2E6%2Eel5>)
- using gnome software updater which installs both xen and non-xen
kernels. The non-xen kernel worked fine without any manual driver
install. Presumably the dkms install worked fine.

When I tried to boot the xen kernel - there were lots of problems -
partly because I recently got the shcpd going on the server - and it now
needs static ips. The xen kernel still seemed to be set to dynamic ips -
but that was easily fixed. Now the message "starting etho - OK" is
displayed - and nearly everything looks OK in the startup messages - but
several things are slow to start. Once it boots - there is no network
connectivity - and the above "vif0.0" errors appear in the messages log.

Can anyone shed any light on these questions?

Thanks

Richard.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos-virt @
categoriescentos
postedJan 28, '08 at 1:51p
activeJan 28, '08 at 1:51p
posts1
users1
websitecentos.org
irc#centos

1 user in discussion

Richard Chapman: 1 post

People

Translate

site design / logo © 2022 Grokbase