FAQ
There are new RPMS released for nx and freenx in the CentOS-4 and
CentOS-5 Extras repository.

I normally do not announce that here, as those can easily be obtained on
a normal "yum upgrade/update", however in this case there are special
actions required *_IF_* you have the x86_64 architecture for either
CentOS-4 or CentOS-5 with the current versions of nx and freenx installed.

The freenx and nx in the x86_64 tree were i386 versions prior to this
release because the nomachine code would not compile on x86_64. This
release fixes that and the new versions are x86_64 RPMS and no longer
i386. This means that YUM will not update the currently installed i386
RPMS that are installed on x86_64 machines.

=============
*_ATTENTION_*
=============

If you are running nx and freenx on x86_64, to get these upgraded you
*_MUST_*:

1. Manually download the x86_64 RPMS from these location:

CentOS-5:
<http://mirror.centos.org/centos/5/extras/x86_64/RPMS/freenx-0.7.1-1.el5.centos.x86_64.rpm>
<http://mirror.centos.org/centos/5/extras/x86_64/RPMS/nx-3.0.0-4.el5.centos.x86_64.rpm>

CentOS-4:
<http://mirror.centos.org/centos/4/extras/x86_64/RPMS/freenx-0.7.1-1.el4.centos.x86_64.rpm>
<http://mirror.centos.org/centos/4/extras/x86_64/RPMS/nx-3.0.0-4.el4.centos.x86_64.rpm>

2. Manually install these two RPMS with this command (as root from
within the directory where you downloaded them):

rpm -Uvh freenx-0.7.1-1.el5.centos.x86_64.rpm
nx-3.0.0-4.el5.centos.x86_64.rpm

(that command is all one line if it wraps on your e-mail)

=============

I apologize for the manual update requirement, however yum will not
update i386 packages with x86_64 ones.

Again ... this is *_ONLY_* required if you have the prior released i386
versions of nx and freenx installed on the X86_64 arch of either
CentOS-4.x or CentOS-5.x.

If you are using the i386 architecture of CentOS-4.x or CentOS-5.x then
you can just upgrade via yum normally.

Thanks,
Johnny Hughes


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
Url : http://lists.centos.org/pipermail/centos-devel/attachments/20071021/99c0918e/signature.bin

Search Discussions

  • Johnny Hughes at Oct 21, 2007 at 2:27 pm

    Johnny Hughes wrote:
    There are new RPMS released for nx and freenx in the CentOS-4 and
    CentOS-5 Extras repository.

    I normally do not announce that here, as those can easily be obtained on
    a normal "yum upgrade/update", however in this case there are special
    actions required *_IF_* you have the x86_64 architecture for either
    CentOS-4 or CentOS-5 with the current versions of nx and freenx installed.

    The freenx and nx in the x86_64 tree were i386 versions prior to this
    release because the nomachine code would not compile on x86_64. This
    release fixes that and the new versions are x86_64 RPMS and no longer
    i386. This means that YUM will not update the currently installed i386
    RPMS that are installed on x86_64 machines.

    =============
    *_ATTENTION_*
    =============

    If you are running nx and freenx on x86_64, to get these upgraded you
    *_MUST_*:

    1. Manually download the x86_64 RPMS from these location:

    CentOS-5:
    <http://mirror.centos.org/centos/5/extras/x86_64/RPMS/freenx-0.7.1-1.el5.centos.x86_64.rpm>
    <http://mirror.centos.org/centos/5/extras/x86_64/RPMS/nx-3.0.0-4.el5.centos.x86_64.rpm>

    CentOS-4:
    <http://mirror.centos.org/centos/4/extras/x86_64/RPMS/freenx-0.7.1-1.el4.centos.x86_64.rpm>
    <http://mirror.centos.org/centos/4/extras/x86_64/RPMS/nx-3.0.0-4.el4.centos.x86_64.rpm>
    *_FORGOT A STEP_*

    1a. Remove the current nx and freenx with this command:

    rpm -e nx freenx

    2. Manually install these two RPMS with this command (as root from
    within the directory where you downloaded them):

    rpm -Uvh freenx-0.7.1-1.el5.centos.x86_64.rpm
    nx-3.0.0-4.el5.centos.x86_64.rpm

    (that command is all one line if it wraps on your e-mail)

    =============

    I apologize for the manual update requirement, however yum will not
    update i386 packages with x86_64 ones.

    Again ... this is *_ONLY_* required if you have the prior released i386
    versions of nx and freenx installed on the X86_64 arch of either
    CentOS-4.x or CentOS-5.x.

    If you are using the i386 architecture of CentOS-4.x or CentOS-5.x then
    you can just upgrade via yum normally.

    Thanks,
    Johnny Hughes




    ------------------------------------------------------------------------

    _______________________________________________
    CentOS-devel mailing list
    CentOS-devel@centos.org
    http://lists.centos.org/mailman/listinfo/centos-devel

    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: signature.asc
    Type: application/pgp-signature
    Size: 252 bytes
    Desc: OpenPGP digital signature
    Url : http://lists.centos.org/pipermail/centos-devel/attachments/20071021/bbc3633a/signature.bin

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcentos-devel @
categoriescentos
postedOct 21, '07 at 1:52p
activeOct 21, '07 at 2:27p
posts2
users1
websitecentos.org
irc#centos

1 user in discussion

Johnny Hughes: 2 posts

People

Translate

site design / logo © 2021 Grokbase