FAQ
Hi,

would be quite useful if on the Download page (or somewhere else)
would be listed what minimal Java version is required for each release
(mostly for the server), since very often the Java version a critical
constraint for adoption.

Thanks in advance.

Adrian.

Search Discussions

  • Andrus Adamchik at Nov 18, 2013 at 6:07 am
    As it stands right now, we have the following JVM requirements:

    Cayenne 3.2 - Java 1.6
    Cayenne 3.1 - Java 1.5
    Cayenne 3.0 - Java 1.5

    We sorta mention it inside user guide [1]. But yeah, having it more pronounced, like Jetty does [2] would certainly be better. In 3.2 “System Requirements” chapter has a full compatibility table. Just that we haven’t published it to the site yet.

    Andrus

    [1] http://cayenne.apache.org/docs/3.1/cayenne-guide/setup.html#system-requirements
    [2] http://www.eclipse.org/jetty/documentation/current/what-jetty-version.html
    On Nov 17, 2013, at 10:39 PM, Adrian A. wrote:
    Hi,

    would be quite useful if on the Download page (or somewhere else)
    would be listed what minimal Java version is required for each release
    (mostly for the server), since very often the Java version a critical
    constraint for adoption.

    Thanks in advance.

    Adrian.
  • Aristedes Maniatis at Nov 18, 2013 at 9:34 am

    On Mon Nov 18 17:06:57 2013, Andrus Adamchik wrote:
    As it stands right now, we have the following JVM requirements:

    Cayenne 3.2 - Java 1.6
    Cayenne 3.1 - Java 1.5
    Cayenne 3.0 - Java 1.5

    We sorta mention it inside user guide [1]. But yeah, having it more pronounced, like Jetty does [2] would certainly be better. In 3.2 “System Requirements” chapter has a full compatibility table. Just that we haven’t published it to the site yet.
    I added this to the download page.

    Ari




    --
    -------------------------->
    Aristedes Maniatis
    GPG fingerprint CBFB 84B4 738D 4E87 5E5C 5EFA EF6A 7D2E 3E49 102A
  • Adrian A. at Nov 18, 2013 at 6:17 pm

    Cayenne 3.2 - Java 1.6
    Cayenne 3.1 - Java 1.5
    Cayenne 3.0 - Java 1.5
    I added this to the download page
    Thank you.

    Will the final 3.1 also support Java 1.5, or this is only for the Beta?


    Adrian.
    On Mon, Nov 18, 2013 at 10:32 AM, Aristedes Maniatis wrote:
    On Mon Nov 18 17:06:57 2013, Andrus Adamchik wrote:
    As it stands right now, we have the following JVM requirements:

    Cayenne 3.2 - Java 1.6
    Cayenne 3.1 - Java 1.5
    Cayenne 3.0 - Java 1.5

    We sorta mention it inside user guide [1]. But yeah, having it more pronounced, like Jetty does [2] would certainly be better. In 3.2 “System Requirements” chapter has a full compatibility table. Just that we haven’t published it to the site yet.
    I added this to the download page.

    Ari




    --
    -------------------------->
    Aristedes Maniatis
    GPG fingerprint CBFB 84B4 738D 4E87 5E5C 5EFA EF6A 7D2E 3E49 102A
  • Andrus Adamchik at Nov 18, 2013 at 7:27 pm

    On Nov 18, 2013, at 9:16 PM, Adrian A. wrote:
    Will the final 3.1 also support Java 1.5, or this is only for the Beta?
    It sure will.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categoriescayenne
postedNov 17, '13 at 7:39p
activeNov 18, '13 at 7:27p
posts5
users3
websitecayenne.apache.org

People

Translate

site design / logo © 2022 Grokbase