FAQ

On 10/10/09 4:17 AM, Andrey Razumovsky (JIRA) wrote:
Andrey Razumovsky commented on CAY-1228:
----------------------------------------

It would also be great if Hudson tested with jdk6 as well as jdk5. Is that possible?
Well, I've made the change. However we got bitten by this bug: http://jira.codehaus.org/browse/SUREFIRE-551. It has been fixed, but in June 2009. The last release of the plugin is 2.4.3 in May 2008. Is it easy for us to move to a snapshot of that plugin? Andrey, if you understand the magic of maven, is that a simple change for you to make?

Here is the failure:
http://hudson.zones.apache.org/hudson/job/Cayenne-trunk/jdk=JDK%201.5%20%28latest%29/lastFailedBuild/console

Once that error is passed, it should build on both 1.5 and 1.6. Plus we get to test on multiple databases within the same Hudson job. But first, I have to find an infra person who will agree to run a few databases...

Ari

--

-------------------------->
Aristedes Maniatis
GPG fingerprint CBFB 84B4 738D 4E87 5E5C 5EFA EF6A 7D2E 3E49 102A

Search Discussions

  • Lachlan Deck at Oct 10, 2009 at 8:25 pm

    On 11/10/2009, at 12:48 AM, Aristedes Maniatis wrote:
    On 10/10/09 4:17 AM, Andrey Razumovsky (JIRA) wrote:
    Andrey Razumovsky commented on CAY-1228:
    ----------------------------------------

    It would also be great if Hudson tested with jdk6 as well as jdk5.
    Is that possible?
    Well, I've made the change. However we got bitten by this bug: http://jira.codehaus.org/browse/SUREFIRE-551
    . It has been fixed, but in June 2009. The last release of the
    plugin is 2.4.3 in May 2008. Is it easy for us to move to a snapshot
    of that plugin? Andrey, if you understand the magic of maven, is
    that a simple change for you to make?
    http://repository.sonatype.org/index.html#nexus-search;quick~maven-surefire-plugin
    latest snapshot version == 2.5-SNAPSHOT

    So you could simply add <version>2.5-SNAPSHOT</version> to the build/
    plugins/plugin:maven-surefire-plugin definition. (the groupId is left
    out as its assumed to be org.apache.maven.plugins).

    However, I'd suggest if this is just a bug for your test machine using
    a profile within a pluginManagement section to make this optional:
    <profiles>
    ...
    <profile>
    <id>hudson.testing</id>
    <activation>
    <activeByDefault>false</activeByDefault>
    <property>
    <name>cayenne.test.hudson</name>
    <value>true</value>
    </property>
    </activation>
    <build>
    <pluginManagement>
    <plugins>
    <plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-surefire-plugin</artifactId>
    <version>2.5-SNAPSHOT</version>
    </plugin>
    </plugins>
    </pluginManagement>
    </build>
    </profile>
    ...
    </profiles>

    Then pass in the property -Dcayenne.test.hudson=true from your hudson
    build.
    Here is the failure:
    http://hudson.zones.apache.org/hudson/job/Cayenne-trunk/jdk=JDK%201.5%20%28latest%29/lastFailedBuild/console

    Once that error is passed, it should build on both 1.5 and 1.6. Plus
    we get to test on multiple databases within the same Hudson job. But
    first, I have to find an infra person who will agree to run a few
    databases...

    Ari

    --

    -------------------------->
    Aristedes Maniatis
    GPG fingerprint CBFB 84B4 738D 4E87 5E5C 5EFA EF6A 7D2E 3E49 102A
    with regards,
    --

    Lachlan Deck

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categoriescayenne
postedOct 10, '09 at 1:48p
activeOct 10, '09 at 8:25p
posts2
users2
websitecayenne.apache.org

People

Translate

site design / logo © 2022 Grokbase