FAQ
Just noticed we have 1 test failure on Hudson that started with this
build:

http://hudson.zones.apache.org/hudson/view/Cayenne/job/Cayenne-trunk/360/

That incorporates multiple commits from 3 people. The only one that
touches CayenneDataObject is this change:

http://fisheye6.atlassian.com/changelog/cayenne/?cs=764184

Andrey, could you please doublecheck this failure?

Thanks,
Andrus

Search Discussions

  • Andrey Razumovsky at Apr 13, 2009 at 7:21 pm
    Weird, everything is running perfect for me locally. Trying to fix.. Another
    strange thing is that mail notifications of failure are no longer sent (and
    build circle is 'yellow', not 'red')

    2009/4/13 Andrus Adamchik <andrus@objectstyle.org>
    Just noticed we have 1 test failure on Hudson that started with this build:

    http://hudson.zones.apache.org/hudson/view/Cayenne/job/Cayenne-trunk/360/

    That incorporates multiple commits from 3 people. The only one that touches
    CayenneDataObject is this change:

    http://fisheye6.atlassian.com/changelog/cayenne/?cs=764184

    Andrey, could you please doublecheck this failure?

    Thanks,
    Andrus
  • Andrus Adamchik at Apr 13, 2009 at 7:33 pm

    On Apr 13, 2009, at 10:21 PM, Andrey Razumovsky wrote:

    Weird, everything is running perfect for me locally.
    This test worked for me when run standalone from Eclipse, but failed
    when run in a batch with maven... So looks like it is affected by the
    prior object state??

    Andrus
  • Andrey Razumovsky at Apr 14, 2009 at 7:23 am
    Well, I fire "mvn clean install" before commit.. This seems a matter of
    enviroment. Nevertheless, everything goes fine now:
    http://hudson.zones.apache.org/hudson/job/Cayenne-trunk/org.apache.cayenne.unpublished$cayenne-jdk1.5-unpublished/

    2009/4/13 Andrus Adamchik <andrus@objectstyle.org>
    On Apr 13, 2009, at 10:21 PM, Andrey Razumovsky wrote:

    Weird, everything is running perfect for me locally.
    This test worked for me when run standalone from Eclipse, but failed when
    run in a batch with maven... So looks like it is affected by the prior
    object state??

    Andrus
  • Aristedes Maniatis at Apr 13, 2009 at 11:49 pm

    On 14/04/2009, at 5:21 AM, Andrey Razumovsky wrote:

    Weird, everything is running perfect for me locally. Trying to fix..
    Another
    strange thing is that mail notifications of failure are no longer
    sent (and
    build circle is 'yellow', not 'red')
    That's because this test failed:

    http://hudson.zones.apache.org/hudson/job/Cayenne-trunk/org.apache.cayenne.unpublished$cayenne-jdk1.5-unpublished/361/testReport/org.apache.cayenne/CayenneDataObjectTest/testReadNestedPropertyToManyInMiddle/

    I think red means it could not compile.


    Also, I just expanded the recipient list to include people who might
    have broken a build and had Hudson send an email when a problem is
    fixed. But it was already set to email dev@c.a.o on failures. Andrus,
    are you able to see if it got stuck in a moderation queue?


    Ari



    -------------------------->
    ish
    http://www.ish.com.au
    Level 1, 30 Wilson Street Newtown 2042 Australia
    phone +61 2 9550 5001 fax +61 2 9550 4001
    GPG fingerprint CBFB 84B4 738D 4E87 5E5C 5EFA EF6A 7D2E 3E49 102A

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categoriescayenne
postedApr 13, '09 at 6:57p
activeApr 14, '09 at 7:23a
posts5
users3
websitecayenne.apache.org

People

Translate

site design / logo © 2022 Grokbase