FAQ
Hi Malcolm,

I am taking this to the list.
On Feb 22, 2007, at 1:32 AM, Malcolm Edgar wrote:
Hi Andrus,

I have completed most of CAY-659, against the STABLE 1.2 branch.

The only piece not done is the deferred loading of descriptions by the
Cayenne runtime, I have a boolean flag option in the MapLoader to
support this functionality. Possibly you can have a look at it to see
how you want it used.

We have been using this build for a week or so now, with now issues.
I was thinking I could check these changes into STABLE 1.2, and once
you are happy with them apply these changes to STABLE 2.0.

I can see its going to be a pain maintaining these two branches.
Actually there is another reason why we can't check it in to 1.2
branch - 1.2 is frozen stable branch and we only add bug fixes to it.
We shouldn't be adding any new features to 1.2 (or 2.0 for that
matter). So officially we can only maintain it on trunk.

At the same time I understand you have a personal need to use it with
1.2? If so you can create your own branch in SVN (1.2-STABLE-CAY-659
or something) and maintain it there. As long as for every change you
log a patch in Jira, so that we can transfer it to trunk at some
point (or you can actually apply it to trunk yourself).

Andrus

Search Discussions

  • Ahmed Mohombe at Feb 22, 2007 at 1:44 pm

    Actually there is another reason why we can't check it in to 1.2 branch
    - 1.2 is frozen stable branch and we only add bug fixes to it. We
    shouldn't be adding any new features to 1.2 (or 2.0 for that matter).
    But the Trunk is not producing the *same* clean and simple distribution as 1.2/2.0 yet (because
    of the maven migration?).

    Ahmed.
  • Malcolm Edgar at Feb 23, 2007 at 12:06 am
    Ok, well all forward on Cayenne 3.0 then.

    If anyone is interested I can post this modified Cayenne 1.2 Modeler
    build on a web server.

    regards Malcolm Edgar
    On 2/22/07, Andrus Adamchik wrote:
    Hi Malcolm,

    I am taking this to the list.
    On Feb 22, 2007, at 1:32 AM, Malcolm Edgar wrote:
    Hi Andrus,

    I have completed most of CAY-659, against the STABLE 1.2 branch.

    The only piece not done is the deferred loading of descriptions by the
    Cayenne runtime, I have a boolean flag option in the MapLoader to
    support this functionality. Possibly you can have a look at it to see
    how you want it used.

    We have been using this build for a week or so now, with now issues.
    I was thinking I could check these changes into STABLE 1.2, and once
    you are happy with them apply these changes to STABLE 2.0.

    I can see its going to be a pain maintaining these two branches.
    Actually there is another reason why we can't check it in to 1.2
    branch - 1.2 is frozen stable branch and we only add bug fixes to it.
    We shouldn't be adding any new features to 1.2 (or 2.0 for that
    matter). So officially we can only maintain it on trunk.

    At the same time I understand you have a personal need to use it with
    1.2? If so you can create your own branch in SVN (1.2-STABLE-CAY-659
    or something) and maintain it there. As long as for every change you
    log a patch in Jira, so that we can transfer it to trunk at some
    point (or you can actually apply it to trunk yourself).

    Andrus
  • Ahmed Mohombe at Feb 23, 2007 at 4:00 pm

    If anyone is interested I can post this modified Cayenne 1.2 Modeler
    build on a web server.
    Yes, please, post it.
    There are just too many projects using Cayenne 1.2, and since 3.0 is not
    "build-able" in a distribution (maven is not producing the same result as ANT yet),
    most projects will stay with it.

    Thanks in advance,

    Ahmed.
    P.S. Maybe we could transform this ticket into' a "bug" request :), to be able
    to apply the patch on 1.2/2.0 :).
  • Andrus Adamchik at Feb 23, 2007 at 4:13 pm
    FYI:

    3.0 (trunk) can be built with Maven for quite some time into a nice
    release assembly:

    http://cayenne.apache.org/building-cayenne.html

    If integration tests are giving you hard time, skip them:

    -Dmaven.test.skip=true

    (at the moment they will, as a bug fix that I submitted for 'geronimo-
    transaction' module hasn't made it to snapshot repo yet; also there
    are bunch of dependencies on SNAPSHOT versions of third party
    modules, so things can get hairy in itests)

    Andrus
  • Ahmed Mohombe at Feb 23, 2007 at 4:53 pm

    3.0 (trunk) can be built with Maven for quite some time into a nice
    release assembly:

    http://cayenne.apache.org/building-cayenne.html
    Yes, but compare the two (1.2/2.0 and 3.0):
    e.g. in /bin there's a 30MB CayenneModeler.jar full of junk files.

    I would like the nice distribution package 1.2/2.0 had back :) (it was so clean and pretty complete).

    Thanks in advance,

    Ahmed.
  • Andrus Adamchik at Feb 23, 2007 at 5:08 pm
    e.g. in /bin there's a 30MB CayenneModeler.jar full of junk files.
    Hmm, indeed - there's lots of junk in that file. Good catch.

    I think this is a result of recent Maven upgrade from 2.0.4 -> 2.0.5.
    I just tried to build with 2.0.4 and got a 5MB file back. Appreciate
    filing a bug - we'll probably need to do some magic with transitive
    dependencies.

    Andrus
  • Ahmed Mohombe at Feb 23, 2007 at 5:18 pm
    I think this is a result of recent Maven upgrade from 2.0.4 -> 2.0.5.
    Yes, I did the upgrade since there was mentioned everywhere that 2.0.5 fixes
    *severe* bugs (I miss ANT :) ).
    Appreciate filing a bug
    OK.

    Is the Cayenne JIRA different from the Apache one(e.g. during the incubator)? It looks like my
    account is not recognized anymore :(.

    Ahmed.
  • Michael Gentry at Feb 23, 2007 at 7:16 pm
    Here is the link I have:

    https://issues.apache.org/cayenne/secure/Dashboard.jspa

    I thought all the Incubator ID's were copied over, though.

    /dev/mrg

    PS. I think I kind of miss Ant, too.

    On 2/23/07, Ahmed Mohombe wrote:
    I think this is a result of recent Maven upgrade from 2.0.4 -> 2.0.5.
    Yes, I did the upgrade since there was mentioned everywhere that 2.0.5 fixes
    *severe* bugs (I miss ANT :) ).
    Appreciate filing a bug
    OK.

    Is the Cayenne JIRA different from the Apache one(e.g. during the incubator)? It looks like my
    account is not recognized anymore :(.

    Ahmed.
  • Ahmed Mohombe at Feb 23, 2007 at 7:22 pm
    I thought all the Incubator ID's were copied over, though.
    Well, during the incubation I was able to use my *Apache* ID (that worked
    in the Cayenne project too).

    Anyway, I already created a new ID - it's faster :).

    Ahmed.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categoriescayenne
postedFeb 22, '07 at 12:58p
activeFeb 23, '07 at 7:22p
posts10
users4
websitecayenne.apache.org

People

Translate

site design / logo © 2022 Grokbase