FAQ
I just checked a fresh copy of trunk out of SVN and get the following
errors when building from scratch. I'm building on WinXP, so I'm not
sure why it's even trying to build a Mac assembly. I don't recall it
ever doing this before.

Anyway, throwing it out there in case anyone knows of a quick POM fix or
something. Otherwise, I'll open up a JIRA and see if I can figure it
out.

--
Kevin

[ERROR] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Compilation failure

C:\Documents and
Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src\main\
java\org\apache\cayenne\modeler\MacOSXSetup.java:[27,22] package
com.apple.eawt does not exist

C:\Documents and
Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src\main\
java\org\apache\cayenne\modeler\MacOSXSetup.java:[28,22] package
com.apple.eawt does not exist

C:\Documents and
Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src\main\
java\org\apache\cayenne\modeler\MacOSXSetup.java:[45,42] cannot find
symbol
symbol : class ApplicationAdapter
location: class org.apache.cayenne.modeler.MacOSXSetup

C:\Documents and
Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src\main\
java\org\apache\cayenne\modeler\MacOSXSetup.java:[47,32] cannot find
symbol
symbol : class ApplicationEvent
location: class org.apache.cayenne.modeler.MacOSXSetup.MacEventsAdapter

C:\Documents and
Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src\main\
java\org\apache\cayenne\modeler\MacOSXSetup.java:[54,31] cannot find
symbol
symbol : class ApplicationEvent
location: class org.apache.cayenne.modeler.MacOSXSetup.MacEventsAdapter

C:\Documents and
Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src\main\
java\org\apache\cayenne\modeler\MacOSXSetup.java:[41,22] package
com.apple.eawt does not exist

Search Discussions

  • Andrus Adamchik at Nov 3, 2006 at 2:51 pm
    Yikes. Assemblies probably shouldn't be in the general build - there
    is platform specific code in them.

    Also the nightly builds are failing for the last couple of weeks.
    Will need to investigate, could be the same reason?

    Andrus

    On Nov 2, 2006, at 6:23 PM, Kevin Menard wrote:

    I just checked a fresh copy of trunk out of SVN and get the following
    errors when building from scratch. I'm building on WinXP, so I'm not
    sure why it's even trying to build a Mac assembly. I don't recall it
    ever doing this before.

    Anyway, throwing it out there in case anyone knows of a quick POM
    fix or
    something. Otherwise, I'll open up a JIRA and see if I can figure it
    out.

    --
    Kevin

    [ERROR] BUILD FAILURE
    [INFO]
    ----------------------------------------------------------------------
    --
    [INFO] Compilation failure

    C:\Documents and
    Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src
    \main\
    java\org\apache\cayenne\modeler\MacOSXSetup.java:[27,22] package
    com.apple.eawt does not exist

    C:\Documents and
    Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src
    \main\
    java\org\apache\cayenne\modeler\MacOSXSetup.java:[28,22] package
    com.apple.eawt does not exist

    C:\Documents and
    Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src
    \main\
    java\org\apache\cayenne\modeler\MacOSXSetup.java:[45,42] cannot find
    symbol
    symbol : class ApplicationAdapter
    location: class org.apache.cayenne.modeler.MacOSXSetup

    C:\Documents and
    Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src
    \main\
    java\org\apache\cayenne\modeler\MacOSXSetup.java:[47,32] cannot find
    symbol
    symbol : class ApplicationEvent
    location: class
    org.apache.cayenne.modeler.MacOSXSetup.MacEventsAdapter

    C:\Documents and
    Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src
    \main\
    java\org\apache\cayenne\modeler\MacOSXSetup.java:[54,31] cannot find
    symbol
    symbol : class ApplicationEvent
    location: class
    org.apache.cayenne.modeler.MacOSXSetup.MacEventsAdapter

    C:\Documents and
    Settings\nirvdrum\workspaces\cayenne\full\assembly\cayenne-osx\src
    \main\
    java\org\apache\cayenne\modeler\MacOSXSetup.java:[41,22] package
    com.apple.eawt does not exist
  • Kevin Menard at Nov 21, 2006 at 3:46 am
    I just checked in a change to the POM that I think will fix this.
    Unfortunately, my PowerBook is out of commission, so if any of the Mac
    folks could take a stab at building the code, I'd appreciate it.

    Thanks,
    Kevin
    -----Original Message-----
    From: Andrus Adamchik
    Sent: Friday, November 03, 2006 9:51 AM
    To: cayenne-dev@incubator.apache.org
    Subject: Re: SVN build problems

    Yikes. Assemblies probably shouldn't be in the general build - there
    is platform specific code in them.

    Also the nightly builds are failing for the last couple of weeks.
    Will need to investigate, could be the same reason?

    Andrus
  • Andrus Adamchik at Nov 21, 2006 at 5:03 am
    I can build the framework from the root pom on Mac just fine, which
    is good. Regarding the assemblies, they are work in progress and
    weren't working anyways (look at their contents - there is nothing in
    there). So, instead I just removed "assembly" module from the main
    pom - this should disable the assemblies until we fix them.

    For now the important assemblies that support building various
    Modeler flavors are under "cayenne/assembly/modeler/cayenne-modeler-
    mac" (*-win, *-java). Coincidentally Mac Modeler assembly is broken,
    but this has something to do with WOProject folks recently adding
    dependencies to the Mac Maven plugin that we really don't need:

    http://objectstyle.org/woproject-old/lists/woproject-dev/
    2006/11/0035.html

    I'll straighten it out with them.

    Andrus


    On Nov 20, 2006, at 10:45 PM, Kevin Menard wrote:
    I just checked in a change to the POM that I think will fix this.
    Unfortunately, my PowerBook is out of commission, so if any of the Mac
    folks could take a stab at building the code, I'd appreciate it.

    Thanks,
    Kevin
    -----Original Message-----
    From: Andrus Adamchik
    Sent: Friday, November 03, 2006 9:51 AM
    To: cayenne-dev@incubator.apache.org
    Subject: Re: SVN build problems

    Yikes. Assemblies probably shouldn't be in the general build - there
    is platform specific code in them.

    Also the nightly builds are failing for the last couple of weeks.
    Will need to investigate, could be the same reason?

    Andrus
  • Andrus Adamchik at Nov 21, 2006 at 5:06 am
    BTW, the profiles that Kevin added are still useful, as we do have to
    deal with platform-specific assemblies sooner or later.

    Andrus

    On Nov 21, 2006, at 12:03 AM, Andrus Adamchik wrote:

    I can build the framework from the root pom on Mac just fine, which
    is good. Regarding the assemblies, they are work in progress and
    weren't working anyways (look at their contents - there is nothing
    in there). So, instead I just removed "assembly" module from the
    main pom - this should disable the assemblies until we fix them.

    For now the important assemblies that support building various
    Modeler flavors are under "cayenne/assembly/modeler/cayenne-modeler-
    mac" (*-win, *-java). Coincidentally Mac Modeler assembly is
    broken, but this has something to do with WOProject folks recently
    adding dependencies to the Mac Maven plugin that we really don't need:

    http://objectstyle.org/woproject-old/lists/woproject-dev/
    2006/11/0035.html

    I'll straighten it out with them.

    Andrus


    On Nov 20, 2006, at 10:45 PM, Kevin Menard wrote:
    I just checked in a change to the POM that I think will fix this.
    Unfortunately, my PowerBook is out of commission, so if any of the
    Mac
    folks could take a stab at building the code, I'd appreciate it.

    Thanks,
    Kevin
    -----Original Message-----
    From: Andrus Adamchik
    Sent: Friday, November 03, 2006 9:51 AM
    To: cayenne-dev@incubator.apache.org
    Subject: Re: SVN build problems

    Yikes. Assemblies probably shouldn't be in the general build - there
    is platform specific code in them.

    Also the nightly builds are failing for the last couple of weeks.
    Will need to investigate, could be the same reason?

    Andrus
  • Andrus Adamchik at Nov 22, 2006 at 12:01 am
    This is fixed - the mac modeler builds again.

    Andrus
    On Nov 21, 2006, at 12:03 AM, Andrus Adamchik wrote:

    For now the important assemblies that support building various
    Modeler flavors are under "cayenne/assembly/modeler/cayenne-modeler-
    mac" (*-win, *-java). Coincidentally Mac Modeler assembly is
    broken, but this has something to do with WOProject folks recently
    adding dependencies to the Mac Maven plugin that we really don't need:

    http://objectstyle.org/woproject-old/lists/woproject-dev/
    2006/11/0035.html

    I'll straighten it out with them.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categoriescayenne
postedNov 2, '06 at 11:23p
activeNov 22, '06 at 12:01a
posts6
users2
websitecayenne.apache.org

2 users in discussion

Andrus Adamchik: 4 posts Kevin Menard: 2 posts

People

Translate

site design / logo © 2021 Grokbase