FAQ
Hi Guys,

Just experimenting with Vista + Apache 2.2 (works fine in debian, oh the
irony)

Anyway, httpd is fine, virtualhosts is fine, I just seem to be stuck
with some random problem regarding permissions. I can list the "It
Works!" file using the default apache configuration. Great!

A sample of my virtualhosts entries is below;

<VirtualHost *:80>
<Directory /www/docs/ftp>
Options FollowSymLinks
AllowOverride None
Order deny,allow
Allow from all
</Directory>
ServerAdmin webmaster@ftp.clonnyserver.com
DocumentRoot /www/docs/ftp
ServerName ftp.clonnyserver.com
ServerAlias ftp.clonnyserver.com
ErrorLog logs/ftp.clonnyserver.com-error_log
CustomLog logs/ftp.clonnyserver.com-access_log common
</VirtualHost>

Have I done this right? Error logs show the following;

[Sun Mar 18 23:53:15 2007] [error] [client 203.59.68.203] Directory
index forbidden by Options directive: C:/www/docs/ftp/

Every single Options directive I could find is set to order allow,deny -
allow all. As you can see I have set the relevant <Directory> directive
for the virtualhost too (the path is correct and contains a basic txt
document)

Is Vista doing something stupid with itspermissions?

Any ideas? Need any more info just ask :)

- Shane Arnold

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

Search Discussions

  • Shane Arnold at Mar 18, 2007 at 3:12 pm
    Oh, and just to clarify, I have since changed;

    <Directory /www/docs/ftp>
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Allow from all
    </Directory>

    to

    <Directory /www/docs/ftp>
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    And included a trailing slash to no success :(

    Shane Arnold wrote:
    Hi Guys,

    Just experimenting with Vista + Apache 2.2 (works fine in debian, oh
    the irony)

    Anyway, httpd is fine, virtualhosts is fine, I just seem to be stuck
    with some random problem regarding permissions. I can list the "It
    Works!" file using the default apache configuration. Great!

    A sample of my virtualhosts entries is below;

    <VirtualHost *:80>
    <Directory /www/docs/ftp>
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Allow from all
    </Directory>
    ServerAdmin webmaster@ftp.clonnyserver.com
    DocumentRoot /www/docs/ftp
    ServerName ftp.clonnyserver.com
    ServerAlias ftp.clonnyserver.com
    ErrorLog logs/ftp.clonnyserver.com-error_log
    CustomLog logs/ftp.clonnyserver.com-access_log common
    </VirtualHost>

    Have I done this right? Error logs show the following;

    [Sun Mar 18 23:53:15 2007] [error] [client 203.59.68.203] Directory
    index forbidden by Options directive: C:/www/docs/ftp/

    Every single Options directive I could find is set to order allow,deny
    - allow all. As you can see I have set the relevant <Directory>
    directive for the virtualhost too (the path is correct and contains a
    basic txt document)

    Is Vista doing something stupid with itspermissions?

    Any ideas? Need any more info just ask :)

    - Shane Arnold

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server
    Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Sander Temme at Mar 18, 2007 at 3:22 pm

    On Mar 18, 2007, at 8:57 AM, Shane Arnold wrote:

    <Directory /www/docs/ftp>
    Options FollowSymLinks <..>
    [Sun Mar 18 23:53:15 2007] [error] [client 203.59.68.203] Directory
    index forbidden by Options directive: C:/www/docs/ftp/
    You need to add the Indexes option to Options and restart your service.
    Every single Options directive I could find is set to order
    allow,deny - allow all. As you can see I have set the relevant
    <Directory> directive for the virtualhost too (the path is correct
    and contains a basic txt document)
    You're requesting the / path, which will cause Apache to serve
    whatever is set in DirectoryIndex (usually index.html) or, in its
    absence, construct a directory listing IF it is allowed to (see above).

    If the operating system doesn't allow httpd to read a file, you'll
    get a different error in the log. The error.log is exactly the right
    place to look for that kind of stuff.

    S.

    --
    sctemme@apache.org http://www.temme.net/sander/
    PGP FP: 51B4 8727 466A 0BC3 69F4 B7B8 B2BE BC40 1529 24AF

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriesapache
postedMar 18, '07 at 2:58p
activeMar 18, '07 at 3:22p
posts3
users2
websitehttpd.apache.org
irc#httpd

2 users in discussion

Shane Arnold: 2 posts Sander Temme: 1 post

People

Translate

site design / logo © 2022 Grokbase