FAQ
I can't see a directory listing for the document root but i see it for
the directories bellow it:

<VirtualHost 10.1.1.103:80>
ServerName yumrepo.s0
DocumentRoot "/var/www/html/yum"
<Directory "/var/www/html/yum">
Options Indexes
Order Allow,Deny
Allow from all
</Directory>
</VirtualHost>

When I go to http://yumrepo.s0 i get this error:
[client 10.1.1.101] Directory index forbidden by Options directive:
/var/www/html/yum/

But at http://yumrepo.s0/5 it shows a directory listing.

There is no .htaccess. This is Fedora Core 5 and Apache 2.2.2

Regards, Clodoaldo Pinto Neto

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

Search Discussions

  • Boyle Owen at Oct 30, 2006 at 11:54 am

    -----Original Message-----
    From: Clodoaldo Pinto Neto
    Sent: Saturday, October 28, 2006 1:11 AM
    To: users@httpd.apache.org
    Subject: [users@httpd] Directory index forbidden by Options directive

    I can't see a directory listing for the document root but i see it for
    the directories bellow it:

    <VirtualHost 10.1.1.103:80>
    ServerName yumrepo.s0
    DocumentRoot "/var/www/html/yum"
    <Directory "/var/www/html/yum">
    Options Indexes
    Order Allow,Deny
    Allow from all
    </Directory>
    </VirtualHost>

    When I go to http://yumrepo.s0 i get this error:
    [client 10.1.1.101] Directory index forbidden by Options directive:
    /var/www/html/yum/
    I can't see anything wrong with this config... You must have something
    else wrong somewhere, eg:

    - you are editing the wrong config file (try putting in a deliberate
    syntax error to check it is detected)
    - you have another VH serving the requests (are the servernames real or
    did you obfuscate them?)
    - there *is* an htaccess file (put AllowOverride None) to be sure

    Rgds,
    Owen Boyle
    Disclaimer: Any disclaimer attached to this message may be ignored.
    But at http://yumrepo.s0/5 it shows a directory listing.

    There is no .htaccess. This is Fedora Core 5 and Apache 2.2.2

    Regards, Clodoaldo Pinto Neto

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP
    Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org

    This message is for the named person's use only. It may contain confidential, proprietary or legally privileged information. No confidentiality or privilege is waived or lost by any mistransmission. If you receive this message in error, please notify the sender urgently and then immediately delete the message and any copies of it from your system. Please also immediately destroy any hardcopies of the message. You must not, directly or indirectly, use, disclose, distribute, print, or copy any part of this message if you are not the intended recipient. The sender's company reserves the right to monitor all e-mail communications through their networks. Any views expressed in this message are those of the individual sender, except where the message states otherwise and the sender is authorised to state them to be the views of the sender's company.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Clodoaldo Pinto Neto at Oct 30, 2006 at 12:29 pm

    2006/10/30, Boyle Owen <Owen.Boyle@swx.com>:
    -----Original Message-----
    From: Clodoaldo Pinto Neto
    Sent: Saturday, October 28, 2006 1:11 AM
    To: users@httpd.apache.org
    Subject: [users@httpd] Directory index forbidden by Options directive

    I can't see a directory listing for the document root but i see it for
    the directories bellow it:

    <VirtualHost 10.1.1.103:80>
    ServerName yumrepo.s0
    DocumentRoot "/var/www/html/yum"
    <Directory "/var/www/html/yum">
    Options Indexes
    Order Allow,Deny
    Allow from all
    </Directory>
    </VirtualHost>

    When I go to http://yumrepo.s0 i get this error:
    [client 10.1.1.101] Directory index forbidden by Options directive:
    /var/www/html/yum/
    I can't see anything wrong with this config... You must have something
    else wrong somewhere, eg:

    - you are editing the wrong config file (try putting in a deliberate
    syntax error to check it is detected)
    I did it and Apache did not reload.
    - you have another VH serving the requests (are the servernames real or
    did you obfuscate them?)
    There is only one VH named yumrepo.s0. Yes it is a real name for an
    intranet. And no other mention of yum elsewhere in the httpd.conf file
    - there *is* an htaccess file (put AllowOverride None) to be sure
    I did it to be sure and still no document root directory listing.

    <VirtualHost 10.1.1.103:80>
    ServerName yumrepo.s0
    DocumentRoot "/var/www/html/yum"
    <Directory "/var/www/html/yum">
    AllowOverride None
    Options Indexes
    Order Allow,Deny
    Allow from all
    </Directory>
    </VirtualHost>

    Regards, Clodoaldo Pinto Neto

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Manuela Vorazzo at Oct 30, 2006 at 1:09 pm
    I've an Apache 2.2 with multiple virtual hosts each of them corresponding
    to a different IP address.

    Can I set a different source IP for each virtual hosts????


    When my server has a client behaviour with another server I would like to
    have different source IP for every virtual hosts.
    I would like that the outgoing address could be the same as the one where
    that particular virtual host is listening to.

    Please let me know!

    Thanks in advance
    Manuciao
  • Joshua Slive at Oct 30, 2006 at 2:22 pm

    On 10/30/06, Manuela.Vorazzo@ssb.it wrote:
    I've an Apache 2.2 with multiple virtual hosts each of them corresponding to
    a different IP address.

    Can I set a different source IP for each virtual hosts????


    When my server has a client behaviour with another server I would like to
    have different source IP for every virtual hosts.
    I would like that the outgoing address could be the same as the one where
    that particular virtual host is listening to.
    No, that is not supported as far as I know. Apache lets the OS
    determine the best route on the client side.

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Joshua Slive at Oct 30, 2006 at 2:20 pm

    On 10/30/06, Boyle Owen wrote:

    I can't see anything wrong with this config... You must have something
    else wrong somewhere, eg:

    - you are editing the wrong config file (try putting in a deliberate
    syntax error to check it is detected)
    - you have another VH serving the requests (are the servernames real or
    did you obfuscate them?)
    - there *is* an htaccess file (put AllowOverride None) to be sure
    Or

    There is another Options directive in httpd.conf (or an Include'd
    config file) overriding that Options.

    Try searching for EVERY Options directive and making sure they ALL
    include indexes. Then assuming that works, you can go back and remove
    them one by one until you find the critical one.

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Boyle Owen at Oct 30, 2006 at 2:22 pm
    I don't know what you're doing wrong... I tried you're config as you
    described it and it works fine. There must be an additional config
    snippet somewhere that is screwing things up for you. Do you have any
    "Includes"?

    To debug further, strip it down to just this VH and check that you get
    the expected behaviour. Then put back all additional complications
    (other VHs, rewrite rules, SSL, whatever...) one piece at a time, until
    it breaks again - maybe that will shed some light on it...

    Rgds,
    Owen Boyle
    Disclaimer: Any disclaimer attached to this message may be ignored.
    -----Original Message-----
    From: Clodoaldo Pinto Neto
    Sent: Monday, October 30, 2006 1:29 PM
    To: users@httpd.apache.org
    Subject: Re: [users@httpd] Directory index forbidden by
    Options directive

    2006/10/30, Boyle Owen <Owen.Boyle@swx.com>:
    -----Original Message-----
    From: Clodoaldo Pinto Neto
    Sent: Saturday, October 28, 2006 1:11 AM
    To: users@httpd.apache.org
    Subject: [users@httpd] Directory index forbidden by
    Options directive
    I can't see a directory listing for the document root but
    i see it for
    the directories bellow it:

    <VirtualHost 10.1.1.103:80>
    ServerName yumrepo.s0
    DocumentRoot "/var/www/html/yum"
    <Directory "/var/www/html/yum">
    Options Indexes
    Order Allow,Deny
    Allow from all
    </Directory>
    </VirtualHost>

    When I go to http://yumrepo.s0 i get this error:
    [client 10.1.1.101] Directory index forbidden by Options
    directive:
    /var/www/html/yum/
    I can't see anything wrong with this config... You must
    have something
    else wrong somewhere, eg:

    - you are editing the wrong config file (try putting in a deliberate
    syntax error to check it is detected)
    I did it and Apache did not reload.
    - you have another VH serving the requests (are the
    servernames real or
    did you obfuscate them?)
    There is only one VH named yumrepo.s0. Yes it is a real name for an
    intranet. And no other mention of yum elsewhere in the httpd.conf file
    - there *is* an htaccess file (put AllowOverride None) to be sure
    I did it to be sure and still no document root directory listing.

    <VirtualHost 10.1.1.103:80>
    ServerName yumrepo.s0
    DocumentRoot "/var/www/html/yum"
    <Directory "/var/www/html/yum">
    AllowOverride None
    Options Indexes
    Order Allow,Deny
    Allow from all
    </Directory>
    </VirtualHost>

    Regards, Clodoaldo Pinto Neto

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP
    Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org

    This message is for the named person's use only. It may contain confidential, proprietary or legally privileged information. No confidentiality or privilege is waived or lost by any mistransmission. If you receive this message in error, please notify the sender urgently and then immediately delete the message and any copies of it from your system. Please also immediately destroy any hardcopies of the message. You must not, directly or indirectly, use, disclose, distribute, print, or copy any part of this message if you are not the intended recipient. The sender's company reserves the right to monitor all e-mail communications through their networks. Any views expressed in this message are those of the individual sender, except where the message states otherwise and the sender is authorised to state them to be the views of the sender's company.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Clodoaldo Pinto Neto at Oct 30, 2006 at 4:08 pm

    2006/10/30, Boyle Owen <Owen.Boyle@swx.com>:
    I don't know what you're doing wrong... I tried you're config as you
    described it and it works fine. There must be an additional config
    snippet somewhere that is screwing things up for you. Do you have any
    "Includes"?

    To debug further, strip it down to just this VH and check that you get
    the expected behaviour. Then put back all additional complications
    (other VHs, rewrite rules, SSL, whatever...) one piece at a time, until
    it breaks again - maybe that will shed some light on it...
    Thanks for the tip. I found the culprit. Fedora Core 5 (i think the
    previous versions also) has a welcome.conf in conf.d:

    <LocationMatch "^/+$">
    Options -Indexes
    ErrorDocument 403 /error/noindex.html
    </LocationMatch>

    Since I like the welcome page I came with this workaround:

    <VirtualHost 10.1.1.103:80>
    ServerName yumrepo.s0
    DocumentRoot "/var/www/html/yum"
    <Location />
    Options Indexes
    </Location>
    <Directory "/var/www/html/yum">
    AllowOverride None
    Options Indexes
    Order Allow,Deny
    Allow from all
    </Directory>
    </VirtualHost>

    I think it is kind of ugly. If you can see something more elegant just say it.

    Regards, Clodoaldo Pinto Neto

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriesapache
postedOct 27, '06 at 11:11p
activeOct 30, '06 at 4:08p
posts8
users4
websitehttpd.apache.org
irc#httpd

People

Translate

site design / logo © 2022 Grokbase