FAQ
Hi,

I'm running apache on a linux station (detailed versions below) and I
get occasional 403 errors (Directory index forbidden). What I mean by
'occasional' is that using the same config files, it works almost well
but fails only on some seldom unpredictable requests (between 1 to 5
times per day).
I'm investigating the problem for a couple of weeks, without success,
but trying a simulation using wget (v. 1.9.1) I've discovered the
following:
using the following script
while [ 1 ]
do
wget -r http://www.myserver.root/
sleep 3
done
I get 2 successful replies followed by 6 or 7 error 403
when I change the sleep delay, the number of failure changes but the
failure period remains around 20 seconds ie: I get 403 errors during 20
sec. after the last successful request.

I can completely avoid these 403 errors using the '--cache=off' on the
wget command line. I'm therefore suspecting that some 'cache strategy'
could be involved in the problem but looking at the documentation, I
can't find any explanation (cache seems to be mainly related to proxy
and there is none in the local config and when I use wget).

Here is some additional information:

- the server and system version numbers:
Apache-AdvancedExtranetServer/2.0.50 (Mandrakelinux/7.3.101mdk)
mod_perl/1.99_16 Perl/v5.8.5 mod_ssl/2.0.50 OpenSSL/0.9.7d PHP/4.3.8
Linux 2.6.8.1-12mdksmp #1 SMP Fri Oct 1 11:24:45 CEST 2004 i686
Intel(R) Pentium(R) 4 CPU 2.80GHz (official Mandrake 10.1)

- some reports from error_log:
[Thu Aug 25 11:15:09 2005] [error] [client 81.199.84.124] Directory
index forbidden by rule: /home/www/html/Creation/Residences/Giroudon/
[Mon Aug 29 17:57:14 2005] [error] [client 194.5.49.22] Directory index
forbidden by rule: /home/www/html/
errors are on any folder, access rights have been controled

- an excerpt of the commonhttpd.conf
<Directory /home/www/html>
Options -Indexes Includes FollowSymLinks -MultiViews
AllowOverride All
<IfModule mod_access.c>
Order allow,deny
Allow from all
</IfModule>
</Directory>

Thanks in advance for any help,
---
Dominique Fober


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

Search Discussions

  • Joshua Slive at Aug 30, 2005 at 3:47 pm

    On 8/29/05, Dominique Fober wrote:
    I'm running apache on a linux station (detailed versions below) and I
    get occasional 403 errors (Directory index forbidden).
    I can completely avoid these 403 errors using the '--cache=off' on the
    wget command line. I'm therefore suspecting that some 'cache strategy'
    could be involved in the problem but looking at the documentation, I
    can't find any explanation (cache seems to be mainly related to proxy
    and there is none in the local config and when I use wget).
    --cache=off tells wget to send Pragma: no-cache, which shouldn't have
    any effect unless there is some cache or proxy between you and the
    server. Are you sure you are directly accessing the server?
    Here is some additional information:

    - the server and system version numbers:
    Apache-AdvancedExtranetServer/2.0.50 (Mandrakelinux/7.3.101mdk)
    mod_perl/1.99_16 Perl/v5.8.5 mod_ssl/2.0.50 OpenSSL/0.9.7d PHP/4.3.8
    Linux 2.6.8.1-12mdksmp #1 SMP Fri Oct 1 11:24:45 CEST 2004 i686
    Intel(R) Pentium(R) 4 CPU 2.80GHz (official Mandrake 10.1)
    Oooo. I get scarded whenever I see that "AdvancedExtranet" stuff.
    That means a version of apache with random extra hacks added. Who
    knows what it will do.
    - some reports from error_log:
    [Thu Aug 25 11:15:09 2005] [error] [client 81.199.84.124] Directory
    index forbidden by rule: /home/www/html/Creation/Residences/Giroudon/
    [Mon Aug 29 17:57:14 2005] [error] [client 194.5.49.22] Directory index
    forbidden by rule: /home/www/html/
    errors are on any folder, access rights have been controled
    - an excerpt of the commonhttpd.conf
    <Directory /home/www/html>
    Options -Indexes Includes FollowSymLinks -MultiViews
    Well, you do have indexes turned off (although your Options line
    doesn't make a lot of sense -- see the docs for Options). Do you have
    a file in those directories that matches the DirectoryIndex directive?

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Dominique Fober at Aug 30, 2005 at 4:20 pm
    Hi Joshua,

    Le 30 août 05, à 17:47, Joshua Slive a écrit :
    On 8/29/05, Dominique Fober wrote:
    I'm running apache on a linux station (detailed versions below) and I
    get occasional 403 errors (Directory index forbidden).
    I can completely avoid these 403 errors using the '--cache=off' on the
    wget command line. I'm therefore suspecting that some 'cache strategy'
    could be involved in the problem but looking at the documentation, I
    can't find any explanation (cache seems to be mainly related to proxy
    and there is none in the local config and when I use wget).
    --cache=off tells wget to send Pragma: no-cache, which shouldn't have
    any effect unless there is some cache or proxy between you and the
    server. Are you sure you are directly accessing the server?
    yes, the station that issues wget and the one with apache server are
    located on the same local network: no router, no proxy.

    Here is some additional information:

    - the server and system version numbers:
    Apache-AdvancedExtranetServer/2.0.50 (Mandrakelinux/7.3.101mdk)
    mod_perl/1.99_16 Perl/v5.8.5 mod_ssl/2.0.50 OpenSSL/0.9.7d PHP/4.3.8
    Linux 2.6.8.1-12mdksmp #1 SMP Fri Oct 1 11:24:45 CEST 2004 i686
    Intel(R) Pentium(R) 4 CPU 2.80GHz (official Mandrake 10.1)
    Oooo. I get scarded whenever I see that "AdvancedExtranet" stuff.
    That means a version of apache with random extra hacks added. Who
    knows what it will do.
    the apache server is as provided with the official mandrake 10.1
    distribution + some updates

    - some reports from error_log:
    [Thu Aug 25 11:15:09 2005] [error] [client 81.199.84.124] Directory
    index forbidden by rule: /home/www/html/Creation/Residences/Giroudon/
    [Mon Aug 29 17:57:14 2005] [error] [client 194.5.49.22] Directory
    index
    forbidden by rule: /home/www/html/
    errors are on any folder, access rights have been controled
    - an excerpt of the commonhttpd.conf
    <Directory /home/www/html>
    Options -Indexes Includes FollowSymLinks -MultiViews
    Well, you do have indexes turned off (although your Options line
    doesn't make a lot of sense -- see the docs for Options). Do you have
    a file in those directories that matches the DirectoryIndex directive?
    yes, there is one (index.html) and the server can find and use it
    almost each time, apart these 'occasional' errors...

    here is also the 'DirectoryIndex' used:
    <IfModule mod_dir.c>
    DirectoryIndex index.html index.html.var index.php index.php3
    index.shtml index.cgi index.pl index.htm Default.htm default.htm
    index.xml
    </IfModule>

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server
    Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
    ---
    Dominique Fober


    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Joshua Slive at Aug 30, 2005 at 4:49 pm

    On 8/30/05, Dominique Fober wrote:
    Here is some additional information:

    - the server and system version numbers:
    Apache-AdvancedExtranetServer/2.0.50 (Mandrakelinux/7.3.101mdk)
    mod_perl/1.99_16 Perl/v5.8.5 mod_ssl/2.0.50 OpenSSL/0.9.7d PHP/4.3.8
    Linux 2.6.8.1-12mdksmp #1 SMP Fri Oct 1 11:24:45 CEST 2004 i686
    Intel(R) Pentium(R) 4 CPU 2.80GHz (official Mandrake 10.1)
    Oooo. I get scarded whenever I see that "AdvancedExtranet" stuff.
    That means a version of apache with random extra hacks added. Who
    knows what it will do.
    the apache server is as provided with the official mandrake 10.1
    distribution + some updates
    Yes, I know. But that could be quite different than the version
    coming from httpd.apache.org.
    - some reports from error_log:
    [Thu Aug 25 11:15:09 2005] [error] [client 81.199.84.124] Directory
    index forbidden by rule: /home/www/html/Creation/Residences/Giroudon/
    [Mon Aug 29 17:57:14 2005] [error] [client 194.5.49.22] Directory
    index
    forbidden by rule: /home/www/html/
    errors are on any folder, access rights have been controled
    - an excerpt of the commonhttpd.conf
    <Directory /home/www/html>
    Options -Indexes Includes FollowSymLinks -MultiViews
    Well, you do have indexes turned off (although your Options line
    doesn't make a lot of sense -- see the docs for Options). Do you have
    a file in those directories that matches the DirectoryIndex directive?
    yes, there is one (index.html) and the server can find and use it
    almost each time, apart these 'occasional' errors...
    I would try running in single-process mode (httpd -X) under strace and
    possibly under a debugger to try to figure out exactly why apache
    can't find the index.html.

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Dominique Fober at Aug 31, 2005 at 8:35 am

    Le 30 août 05, à 18:48, Joshua Slive a écrit :
    On 8/30/05, Dominique Fober wrote:
    Here is some additional information:

    - the server and system version numbers:
    Apache-AdvancedExtranetServer/2.0.50 (Mandrakelinux/7.3.101mdk)
    mod_perl/1.99_16 Perl/v5.8.5 mod_ssl/2.0.50 OpenSSL/0.9.7d PHP/4.3.8
    Linux 2.6.8.1-12mdksmp #1 SMP Fri Oct 1 11:24:45 CEST 2004 i686
    Intel(R) Pentium(R) 4 CPU 2.80GHz (official Mandrake 10.1)
    Oooo. I get scarded whenever I see that "AdvancedExtranet" stuff.
    That means a version of apache with random extra hacks added. Who
    knows what it will do.
    the apache server is as provided with the official mandrake 10.1
    distribution + some updates
    Yes, I know. But that could be quite different than the version
    coming from httpd.apache.org.
    - some reports from error_log:
    [Thu Aug 25 11:15:09 2005] [error] [client 81.199.84.124] Directory
    index forbidden by rule:
    /home/www/html/Creation/Residences/Giroudon/
    [Mon Aug 29 17:57:14 2005] [error] [client 194.5.49.22] Directory
    index
    forbidden by rule: /home/www/html/
    errors are on any folder, access rights have been controled
    - an excerpt of the commonhttpd.conf
    <Directory /home/www/html>
    Options -Indexes Includes FollowSymLinks -MultiViews
    Well, you do have indexes turned off (although your Options line
    doesn't make a lot of sense -- see the docs for Options). Do you
    have
    a file in those directories that matches the DirectoryIndex
    directive?
    yes, there is one (index.html) and the server can find and use it
    almost each time, apart these 'occasional' errors...
    I would try running in single-process mode (httpd -X) under strace and
    possibly under a debugger to try to figure out exactly why apache
    can't find the index.html.
    thanks a lot for the suggestion!
    Trying to change the command line options, I've discovered that httpd
    is launched with a whole bunch of -D options. First of all, I feel a
    little bit brainless for not having looked at these options earlier.
    Here there are:

    httpd2 -f /etc/httpd/conf/httpd2.conf -DAPACHE2 -DHAVE_PERL -DHAVE_PHP4
    -DHAVE_SSL -DHAVE_SUEXEC -DHAVE_ACCESS -DHAVE_ACTIONS -DHAVE_ALIAS
    -DHAVE_ASIS -DHAVE_AUTH_ANON -DHAVE_AUTH_DBM -DHAVE_AUTH_DIGEST
    -DHAVE_AUTH -DHAVE_AUTOINDEX -DHAVE_CACHE -DHAVE_CASE_FILTER_IN
    -DHAVE_CASE_FILTER -DHAVE_CERN_META -DHAVE_CGID -DHAVE_CGI
    -DHAVE_CHARSET_LITE -DHAVE_DIR -DHAVE_DISK_CACHE -DHAVE_ENV
    -DHAVE_EXPIRES -DHAVE_EXT_FILTER -DHAVE_HEADERS -DHAVE_IMAP
    -DHAVE_INCLUDE -DHAVE_INFO -DHAVE_LOG_CONFIG -DHAVE_LOG_FORENSIC
    -DHAVE_LOGIO -DHAVE_MIME_MAGIC -DHAVE_MIME -DHAVE_NEGOTIATION
    -DHAVE_PROXY_CONNECT -DHAVE_PROXY_FTP -DHAVE_PROXY_HTTP -DHAVE_PROXY
    -DHAVE_REWRITE -DHAVE_SETENVIF -DHAVE_SPELING -DHAVE_STATUS
    -DHAVE_UNIQUE_ID -DHAVE_USERDIR -DHAVE_USERTRACK -DHAVE_VHOST_ALIAS

    When I remove the proxy related options (-DHAVE_PROXY_CONNECT
    -DHAVE_PROXY_FTP -DHAVE_PROXY_HTTP -DHAVE_PROXY)
    the occasional 403 error problem disappear.
    Do you think it's a bug (or an unexpected behavior)? should I send a
    report to the apache modules mailing list?
    ---
    Dominique Fober


    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Joshua Slive at Aug 31, 2005 at 1:26 pm

    On 8/31/05, Dominique Fober wrote:

    When I remove the proxy related options (-DHAVE_PROXY_CONNECT
    -DHAVE_PROXY_FTP -DHAVE_PROXY_HTTP -DHAVE_PROXY)
    the occasional 403 error problem disappear.
    Do you think it's a bug (or an unexpected behavior)? should I send a
    report to the apache modules mailing list?
    It would be the apache-httpd bug database, not the modules mailing
    list. But I think it is at least equally probable that the bug is
    specific to something mandrake has done, and there is really not
    enough information to diagnose it further. To get that information,
    you really need to do some more debugging as I suggested in a previous
    message.

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Dominique Fober at Aug 31, 2005 at 3:10 pm

    Le 31 août 05, à 15:25, Joshua Slive a écrit :
    On 8/31/05, Dominique Fober wrote:

    When I remove the proxy related options (-DHAVE_PROXY_CONNECT
    -DHAVE_PROXY_FTP -DHAVE_PROXY_HTTP -DHAVE_PROXY)
    the occasional 403 error problem disappear.
    Do you think it's a bug (or an unexpected behavior)? should I send a
    report to the apache modules mailing list?
    It would be the apache-httpd bug database, not the modules mailing
    list. But I think it is at least equally probable that the bug is
    specific to something mandrake has done, and there is really not
    enough information to diagnose it further. To get that information,
    you really need to do some more debugging as I suggested in a previous
    message.
    you're right. Moreover, maybe I've been in a hurry to announce that it
    solves the problem. What I'm sure now is that with the proxy options I
    can reproduce the problem at will, but it seems to me I've also got a
    403 error without them (but can't reproduce). Thus, here is the strace
    output that leads to the 403 error:

    this is the poll after the last successful request
    16:35:46 poll([{fd=4, events=POLLIN, revents=POLLIN}, {fd=3,
    events=POLLIN}], 2, -1) = 1

    here the wget script waits for 3 seconds...
    16:35:49 accept(4, {sa_family=AF_INET6, sin6_port=htons(38301),
    inet_pton(AF_INET6, "::ffff:194.5.49.22", &sin6_addr), sin6_flowinfo=0,
    sin6_scope_id=0}, [28]) = 21
    16:35:49 fcntl64(20, F_SETLKW, {type=F_UNLCK, whence=SEEK_SET, start=0,
    len=0}) = 0
    16:35:49 getsockname(21, {sa_family=AF_INET6, sin6_port=htons(80),
    inet_pton(AF_INET6, "::ffff:194.5.49.28", &sin6_addr), sin6_flowinfo=0,
    sin6_scope_id=0}, [28]) = 0
    16:35:49 fcntl64(21, F_GETFL) = 0x2 (flags O_RDWR)
    16:35:49 fcntl64(21, F_SETFL, O_RDWR|O_NONBLOCK) = 0
    16:35:49 read(21, "GET / HTTP/1.0\r\nUser-Agent: Wget"..., 8000) = 99
    16:35:49 gettimeofday({1125498949, 934828}, NULL) = 0
    16:35:49 stat64("/home/www/html/", {st_mode=S_IFDIR|0755, st_size=4096,
    ...}) = 0
    16:35:49 lstat64("/home", {st_mode=S_IFDIR|0751, st_size=4096, ...}) = 0
    16:35:49 lstat64("/home/www", {st_mode=S_IFDIR|0751, st_size=4096,
    ...}) = 0
    16:35:49 lstat64("/home/www/html", {st_mode=S_IFDIR|0755, st_size=4096,
    ...}) = 0
    16:35:49 open("/home/www/html/.htaccess", O_RDONLY) = -1 ENOENT (No
    such file or directory)
    16:35:49 open("/var/cache/httpd/HPG/_fl/4vT/gn5/TI7/KwxGxaA.data",
    O_RDONLY) = 22
    16:35:49 open("/var/cache/httpd/HPG/_fl/4vT/gn5/TI7/KwxGxaA.header",
    O_RDONLY) = 23
    16:35:49 fstat64(22, {st_mode=S_IFREG|0600, st_size=545, ...}) = 0
    16:35:49 read(23, "0", 1) = 1
    16:35:49 read(23, "0", 1) = 1
    16:35:49 read(23, "0", 1) = 1
    16:35:49 read(23, "3", 1) = 1
    etc..
    ------------------------------------------------------------------------
    ---------------------
    in fact, it reads the cached header file which content is:
    0003FFA2A3F5F180 0003FFA2A5642780 0000000000000000 0003FFA2A3F51473
    0003FFA2A3F5F180
    X-NAME: nrd.grame.fr/index.html?
    Last-Modified: Tue, 30 Aug 2005 11:00:24 GMT
    Content-Length: 545
    Content-Type: text/plain
    ETag: "6147da-221-84d1a200"
    Accept-Ranges: bytes
    Date: Wed, 31 Aug 2005 14:35:30 GMT

    200
    200 OK

    User-Agent: Wget/1.9.1
    Host: nrd.grame.fr
    Accept: */*
    Connection: Keep-Alive
    Referer: http://nrd.grame.fr/menu.html

    ... eof
    ------------------------------------------------------------------------
    ---------------------
    16:35:49 close(23) = 0
    16:35:49 close(22) = 0
    16:35:49 open("/var/cache/httpd/d8t/x@o/7r0/6FN/u0G/3Blc9Vw.data",
    O_RDONLY) = -1 ENOENT (No such file or directory)

    and here is the strange part: it looks for 'index.html.var' (instead of
    index.html) which is of course not found
    16:35:49 stat64("/home/www/html/index.html.var", 0xbfffe9ec) = -1
    ENOENT (No such file or directory)
    16:35:49 lstat64("/home", {st_mode=S_IFDIR|0751, st_size=4096, ...}) = 0
    16:35:49 lstat64("/home/www", {st_mode=S_IFDIR|0751, st_size=4096,
    ...}) = 0
    16:35:49 lstat64("/home/www/html", {st_mode=S_IFDIR|0755, st_size=4096,
    ...}) = 0
    16:35:49 lstat64("/home/www/html/index.html.var", 0xbfffe9cc) = -1
    ENOENT (No such file or directory)
    16:35:49 open("/var/cache/httpd/H2k/qEQ/s6A/3fg/Rnr/50Oqi6A.data",
    O_RDONLY) = -1 ENOENT (No such file or directory)

    and continue to look for alternate index files which are not present
    until it decides that it's a 403 error
    16:35:49 stat64("/home/www/html/index.php", 0xbfffe9ec) = -1 ENOENT (No
    such file or directory)
    etc...

    for memory:
    DirectoryIndex index.html index.html.var index.php index.php3
    index.shtml index.cgi index.pl index.htm Default.htm default.htm
    index.xml

    ---
    Dominique Fober


    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Dominique Fober at Aug 31, 2005 at 3:20 pm
    last minute infromation: the problem seems to be also related to the
    -DHAVE_CACHE -DHAVE_DISK_CACHE options
    I'll make further investigations.

    Le 31 août 05, à 15:25, Joshua Slive a écrit :
    On 8/31/05, Dominique Fober wrote:

    When I remove the proxy related options (-DHAVE_PROXY_CONNECT
    -DHAVE_PROXY_FTP -DHAVE_PROXY_HTTP -DHAVE_PROXY)
    the occasional 403 error problem disappear.
    Do you think it's a bug (or an unexpected behavior)? should I send a
    report to the apache modules mailing list?
    It would be the apache-httpd bug database, not the modules mailing
    list. But I think it is at least equally probable that the bug is
    specific to something mandrake has done, and there is really not
    enough information to diagnose it further. To get that information,
    you really need to do some more debugging as I suggested in a previous
    message.

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server
    Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
    --dom


    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Joshua Slive at Aug 31, 2005 at 3:42 pm

    On 8/31/05, Dominique Fober wrote:
    last minute infromation: the problem seems to be also related to the
    -DHAVE_CACHE -DHAVE_DISK_CACHE options
    I'll make further investigations.
    Exactly. You are running mod_disk_cache and it is having some problem
    accessing the cache file. Turn that off. I have no idea why Mandrake
    would have that enabled.

    In general, I wouldn't recommend any usage of mod_cache under apache
    2.0 unless you really know what you are doing. mod_cache is much
    better supported under 2.1 and the forthcoming 2.2.

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Dominique Fober at Aug 31, 2005 at 4:49 pm
    thanks a lot for your help!

    Le 31 août 05, à 17:42, Joshua Slive a écrit :
    On 8/31/05, Dominique Fober wrote:
    last minute infromation: the problem seems to be also related to the
    -DHAVE_CACHE -DHAVE_DISK_CACHE options
    I'll make further investigations.
    Exactly. You are running mod_disk_cache and it is having some problem
    accessing the cache file. Turn that off. I have no idea why Mandrake
    would have that enabled.

    In general, I wouldn't recommend any usage of mod_cache under apache
    2.0 unless you really know what you are doing. mod_cache is much
    better supported under 2.1 and the forthcoming 2.2.

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server
    Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
    --dom


    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriesapache
postedAug 29, '05 at 4:44p
activeAug 31, '05 at 4:49p
posts10
users2
websitehttpd.apache.org
irc#httpd

2 users in discussion

Dominique Fober: 6 posts Joshua Slive: 4 posts

People

Translate

site design / logo © 2022 Grokbase