FAQ
I have a root directory with LDAP working. Here's what the directive
looks like:
<Directory "/root">
Options Includes FollowSymLinks
AuthName "Description goes here"
AuthLDAPURL ldaps://blah.blah.blah...
AuthType Basic
require valid-user
AllowOverride None
Order allow,deny
Allow from all
</Directory>

My problem is: I want to disable LDAP for a subdirectory called images
without affecting anything else. There doesn't seem to be any directive
like 'require none' or .AuthType none' to turn it off for a
subdirectory. I tried something like below, but the directive above
still prompts for a password.
<Directory "/root/*/pathTo/images">
Options Includes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
</Directory>

Anyone know how to disable LDAP just for this images subdirectory?

Thanks in advance,
Chris



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

Search Discussions

  • Christopher R Newman at Jun 10, 2005 at 7:18 pm
    Oops. Just found there is an 'AuthLDAPEnabled off' directive, but I
    restarted the server and I still have the same problem. :(

    Chris

    Christopher R Newman wrote:
    I have a root directory with LDAP working. Here's what the directive
    looks like:
    <Directory "/root">
    Options Includes FollowSymLinks
    AuthName "Description goes here"
    AuthLDAPURL ldaps://blah.blah.blah...
    AuthType Basic
    require valid-user
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    My problem is: I want to disable LDAP for a subdirectory called images
    without affecting anything else. There doesn't seem to be any
    directive like 'require none' or .AuthType none' to turn it off for a
    subdirectory. I tried something like below, but the directive above
    still prompts for a password.
    <Directory "/root/*/pathTo/images">
    Options Includes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    Anyone know how to disable LDAP just for this images subdirectory?

    Thanks in advance,
    Chris



    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server
    Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
    --
    ======================================================================
    Chris Newman Alcatel USA Work:(919)850-5586
    Software Engineer 2301 Sugar Bush Rd. Fax:(919)850-6160
    Test Automation Raleigh, NC 27601 Christopher.Newman@alcatel.com
    ======================================================================




    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Joshua Slive at Jun 10, 2005 at 7:39 pm

    On 6/10/05, Christopher R Newman wrote:

    My problem is: I want to disable LDAP for a subdirectory called images
    without affecting anything else. There doesn't seem to be any directive
    like 'require none' or .AuthType none' to turn it off for a
    subdirectory.
    Satisfy Any
    Allow from all

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Christopher R Newman at Jun 10, 2005 at 8:09 pm
    Didn't even need to use the AuthLDAP enabled directive. Makes sense now
    that I know about it. Thanks a bunch!

    Chris

    Joshua Slive wrote:
    On 6/10/05, Christopher R Newman wrote:


    My problem is: I want to disable LDAP for a subdirectory called images
    without affecting anything else. There doesn't seem to be any directive
    like 'require none' or .AuthType none' to turn it off for a
    subdirectory.
    Satisfy Any
    Allow from all

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriesapache
postedJun 10, '05 at 7:11p
activeJun 10, '05 at 8:09p
posts4
users2
websitehttpd.apache.org
irc#httpd

People

Translate

site design / logo © 2022 Grokbase