Grokbase Groups Apache users May 2005
FAQ
For some reason, I'm getting the following error message in the logfile for
a new virtual host (in addition to getting a 403 Forbidden when trying to
pull up the directory index):

[Sun May 15 17:10:59 2005] [crit] [client 207.144.230.112] (13)Permission
denied: /home/shadowtaint/public_ht
ml/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

despie the fact that there is an empty .htaccess file that has the proper
permissions (I have .htaccess enabled for those who want to use it). I've
disabled .htaccess support and restarted and I get the same error meessage
and the same 403 Forbidden message when trying to pull up the directory
index of the vhost. What's up?

I'm thinking I just need a second pair of eyes at my vhost conf for this
person so here it is:

<VirtualHost *>
DocumentRoot /home/shadowtaint/public_html/
ServerName shadowtaint.joseph-a-nagy-jr.us
CustomLog /home/jnagyjr/logs/shadowtaint-access.log combined
ErrorLog /home/jnagyjr/logs/shadowtaint-error.log
ScriptAlias /cgi-bin/ /home/shadowtaint/public_html/cgi-bin/
<Directory "/home/shadowtaint/public_html">
Options All Multiviews
</Directory>
<Directory "/home/shadowtaint/public_html/cgi-bin">
AllowOverride None
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

TIA

Search Discussions

  • Gene at May 16, 2005 at 2:52 pm
    Which OS - If *nix, what does ls -l show for the directory chain and
    ,htaccess?

    Gene

    Joseph A Nagy Jr wrote:
    For some reason, I'm getting the following error message in the
    logfile for a new virtual host (in addition to getting a 403 Forbidden
    when trying to pull up the directory index):

    [Sun May 15 17:10:59 2005] [crit] [client 207.144.230.112]
    (13)Permission denied: /home/shadowtaint/public_ht
    ml/.htaccess pcfg_openfile: unable to check htaccess file, ensure it
    is readable

    despie the fact that there is an empty .htaccess file that has the
    proper permissions (I have .htaccess enabled for those who want to use
    it). I've disabled .htaccess support and restarted and I get the same
    error meessage and the same 403 Forbidden message when trying to pull
    up the directory index of the vhost. What's up?

    I'm thinking I just need a second pair of eyes at my vhost conf for
    this person so here it is:

    <VirtualHost *>
    DocumentRoot /home/shadowtaint/public_html/
    ServerName shadowtaint.joseph-a-nagy-jr.us
    CustomLog /home/jnagyjr/logs/shadowtaint-access.log combined
    ErrorLog /home/jnagyjr/logs/shadowtaint-error.log
    ScriptAlias /cgi-bin/ /home/shadowtaint/public_html/cgi-bin/
    <Directory "/home/shadowtaint/public_html">
    Options All Multiviews
    </Directory>
    <Directory "/home/shadowtaint/public_html/cgi-bin">
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>

    TIA


    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org
  • Joseph A Nagy Jr at May 16, 2005 at 7:14 pm

    Gene wrote:
    Which OS - If *nix, what does ls -l show for the directory chain and
    ,htaccess?

    Gene
    <snip>

    File permissions are always the last thing I look at, I don't know why. ):

    Thanks though. (:
  • Joshua Slive at May 16, 2005 at 4:47 pm

    On 5/15/05, Joseph A Nagy Jr wrote:
    For some reason, I'm getting the following error message in the logfile for
    a new virtual host (in addition to getting a 403 Forbidden when trying to
    pull up the directory index):

    [Sun May 15 17:10:59 2005] [crit] [client 207.144.230.112] (13)Permission
    denied: /home/shadowtaint/public_ht
    ml/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
    This indicates that apache tried to check for the .htaccess file, but
    filesystem permissions prevented it.
    despie the fact that there is an empty .htaccess file that has the proper
    permissions (I have .htaccess enabled for those who want to use it). I've
    disabled .htaccess support and restarted and I get the same error meessage
    and the same 403 Forbidden message when trying to pull up the directory
    index of the vhost. What's up?
    If you had really disabled .htaccess (by setting AllowOverride none
    for that directory) then the problem would have disappeared, so I
    suspect you didn't disable it properly.

    But if you want to use .htaccess, what you need to do is fix the
    filesystem permissions on the file and directory in question.

    Joshua.

    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project.
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    " from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriesapache
postedMay 15, '05 at 10:17p
activeMay 16, '05 at 7:14p
posts4
users3
websitehttpd.apache.org
irc#httpd

People

Translate

site design / logo © 2022 Grokbase