FAQ
Hi,

I am using replicated leveldb and broker was running fine. Suddenly after a
restart we ran into below issue where broker was continuously throwing below
exception and not able to start.


org.apache.activemq.leveldb.util.Log$class#debug 112 DEBUG] - Could not load
factory: org.fusesource.l
eveldbjni.JniDBFactory due to: java.lang.NoClassDefFoundError: Could not
initialize class org.fusesource.leveldbjni.JniDBFactory
[20151124 04:58:44.401 EST (hawtdispatch-DEFAULT-1)
org.apache.activemq.leveldb.util.Log$class#info 93 INFO] - Using the pure
java LevelDB implementation.

[20151124 04:58:44.401 EST (hawtdispatch-DEFAULT-1)
org.apache.activemq.leveldb.util.Log$class#info 93 INFO] - Attaching to
master: tcp://a.b.c.d:37792
[20151124 04:58:44.402 EST (hawtdispatch-DEFAULT-1)
org.apache.activemq.leveldb.util.Log$class#warn 75 WARN] - Unexpected
session error: java.net.ConnectException: Connection refused [20151124
04:58:45.403 EST (hawtdispatch-DEFAULT-1)

Thanks,
Anuj

Search Discussions

  • Tim Bain at Nov 30, 2015 at 2:14 pm
    I assume that in the intervening week you've figured out that the two are
    unrelated, and that a DEBUG-level NoClassDefFoundException followed by an
    INFO-level line that says that we're using an alternative instead isn't
    actually a problem.

    Did you figure out why you were unable to connect?
    On Nov 24, 2015 7:10 AM, "khandelwalanuj" wrote:

    Hi,

    I am using replicated leveldb and broker was running fine. Suddenly after a
    restart we ran into below issue where broker was continuously throwing
    below
    exception and not able to start.


    org.apache.activemq.leveldb.util.Log$class#debug 112 DEBUG] - Could not
    load
    factory: org.fusesource.l
    eveldbjni.JniDBFactory due to: java.lang.NoClassDefFoundError: Could not
    initialize class org.fusesource.leveldbjni.JniDBFactory
    [20151124 04:58:44.401 EST (hawtdispatch-DEFAULT-1)
    org.apache.activemq.leveldb.util.Log$class#info 93 INFO] - Using the pure
    java LevelDB implementation.

    [20151124 04:58:44.401 EST (hawtdispatch-DEFAULT-1)
    org.apache.activemq.leveldb.util.Log$class#info 93 INFO] - Attaching to
    master: tcp://a.b.c.d:37792
    [20151124 04:58:44.402 EST (hawtdispatch-DEFAULT-1)
    org.apache.activemq.leveldb.util.Log$class#warn 75 WARN] - Unexpected
    session error: java.net.ConnectException: Connection refused [20151124
    04:58:45.403 EST (hawtdispatch-DEFAULT-1)

    Thanks,
    Anuj



    --
    View this message in context:
    http://activemq.2283324.n4.nabble.com/ActiveMQ-5-11-leveld-error-java-lang-NoClassDefFoundError-Could-not-initialize-class-org-fusesource--tp4704232.html
    Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriesactivemq
postedNov 24, '15 at 2:10p
activeNov 30, '15 at 2:14p
posts2
users2
websiteactivemq.apache.org

2 users in discussion

Khandelwalanuj: 1 post Tim Bain: 1 post

People

Translate

site design / logo © 2022 Grokbase