FAQ
I have a JNDI configuration for an embedded broker in my Tomcat context.xml,
I'm trying to use the broker uri syntax to configure the broker and having
varied luck. My configuration works until I try to add the useJmx option to
the URI. When I add useJmx=false I get the following on tomcat startup:

SEVERE: Parse Fatal Error at line 37 column 134: The reference to entity
"broker.useJmx" must end with the ';' delimiter.
org.xml.sax.SAXParseException: The reference to entity "broker.useJmx" must
end with the ';' delimiter.>...at
com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)

Can anyone help me figure out what I am doing wrong in my broker config
syntax?

Here is my resource in tomcat:


<Resource name="jms/connectionFactory" auth="Container"
type="org.apache.activemq.ActiveMQConnectionFactory"
description="JMS Connection Factory Home"
factory="org.apache.activemq.jndi.JNDIReferenceFactory"
brokerURL="vm://localhost?broker.persistent=false"
brokerName="sharedAuditBroker"/>

The above works, but when I change brokerURL to:


brokerURL="vm://localhost?broker.persistent=false&useJmx=false"

or

brokerURL="vm://localhost?broker.persistent=false&broker.useJmx=false"

I get the error listed above.

Thanks for any insight on this!


--
View this message in context: http://activemq.2283324.n4.nabble.com/Broker-URI-configuration-causing-SAX-errors-tp3038143p3038143.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Search Discussions

  • Dejan Bosanac at Nov 11, 2010 at 5:30 pm
    Try using &amp; instead of &


    Cheers
    --
    Dejan Bosanac
    -----------------
    FuseSource - The experts in open source integration and messaging.
    Email: dejanb@fusesource.com
    Web: http://fusesource.com
    Twitter:  http://twitter.com/dejanb
    ActiveMQ in Action - http://www.manning.com/snyder/
    Blog - http://www.nighttale.net


    On Thu, Nov 11, 2010 at 5:28 PM, mikey wrote:

    I have a JNDI configuration for an embedded broker in my Tomcat context.xml,
    I'm trying to use the broker uri syntax to configure the broker and having
    varied luck.  My configuration works until I try to add the useJmx option to
    the URI.  When I add useJmx=false I get the following on tomcat startup:

    SEVERE: Parse Fatal Error at line 37 column 134: The reference to entity
    "broker.useJmx" must end with the ';' delimiter.
    org.xml.sax.SAXParseException: The reference to entity "broker.useJmx" must
    end with the ';' delimiter.>...at
    com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)

    Can anyone help me figure out what I am doing wrong in my broker config
    syntax?

    Here is my resource in tomcat:


    <Resource name="jms/connectionFactory" auth="Container"
    type="org.apache.activemq.ActiveMQConnectionFactory"
    description="JMS Connection Factory Home"
    factory="org.apache.activemq.jndi.JNDIReferenceFactory"
    brokerURL="vm://localhost?broker.persistent=false"
    brokerName="sharedAuditBroker"/>

    The above works, but when I change brokerURL to:


    brokerURL="vm://localhost?broker.persistent=false&useJmx=false"

    or

    brokerURL="vm://localhost?broker.persistent=false&broker.useJmx=false"

    I get the error listed above.

    Thanks for any insight on this!


    --
    View this message in context: http://activemq.2283324.n4.nabble.com/Broker-URI-configuration-causing-SAX-errors-tp3038143p3038143.html
    Sent from the ActiveMQ - User mailing list archive at Nabble.com.
  • Mikey at Nov 11, 2010 at 7:21 pm
    Doh! Didn't even think about encoding. That fixed it, thanks and sorry.
    While I have your ear, one more quick question if I may...

    There is a parameter to configure the broker that disables the scheduler and
    I'm fairly confident I don't need the scheduler running, can you tell me
    what that param is? I don't see it on the broker uri documentation page.

    Thanks!
    --
    View this message in context: http://activemq.2283324.n4.nabble.com/Broker-URI-configuration-causing-SAX-errors-tp3038143p3038390.html
    Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriesactivemq
postedNov 11, '10 at 4:27p
activeNov 11, '10 at 7:21p
posts3
users2
websiteactivemq.apache.org

2 users in discussion

Mikey: 2 posts Dejan Bosanac: 1 post

People

Translate

site design / logo © 2022 Grokbase