FAQ
Thanks Chuck. Let me see if I can change the startup script.

Tom

On Tue, Jul 9, 2013 at 8:47 PM, Caldarale, Charles R wrote:

From: Thomas Edison
Subject: java.lang.NoClassDefFoundError
*This is what I see when I start the webhdfs service:*
Using CLASSPATH: /usr/share/tomcat7/bin/bootstrap.jar
Whatever script you're using to start Tomcat has a serious error in it:
the "Using CLASSPATH" message should include tomcat-juli.jar in the same
directory as bootstrap.jar. Without that, Tomcat cannot start.
*What I believe:*
Tomcat didn't load the jar file correctly.
No; the startup script didn't set the command line parameters properly, so
the JVM could not find the logging classes.
I also copied the tomcat-juli.jar file to the following location and restart
the service, but it still doesn't work.
A very, very wrong thing to do. The tomcat-juli.jar must only be in
Tomcat's bin directory; do not attempt to move it or copy it. Fix the
startup script to build the command line properly.

- Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
MATERIAL and is thus for use only by the intended recipient. If you
received this in error, please contact the sender and delete the e-mail and
its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 3 of 3 | next ›
Discussion Overview
groupusers @
categoriestomcat
postedJul 10, '13 at 1:41a
activeJul 10, '13 at 4:08a
posts3
users2
websitetomcat.apache.org
irc#tomcat

People

Translate

site design / logo © 2021 Grokbase