I suspect, but have no proof at this point that something is
accidentially deleting the files from the closed directory during the
build process (possibly after or during failed builds).

I ran into the exact same problem and was scratching my head -- the
same tree worked until a few updates, which were than backed out, and
still failed after backing out. Then instead of just verifying the
closed dir was the correct value (which is what I was doing for a
while -- I was assuming it merely couldn't find closed/), I actually
looked closer and and found libc_i18n.a gone in there (but other stuff
still in there). I hadn't considered it a possibility initially since
nothing I had done would (in my mind at least) remove just that file
(or really otherwise touch /closed).

Try to explicitly recreate the closed dir from the tarballs.

On Thu, Dec 11, 2008 at 11:12 AM, Piotr Jasiukajtis

Does anyone have a problem with building libc lately?
I get this from nightly:

Warning: closed binaries not properly unpacked.
Missing libc_i18n.a
*** Error code 1
The following command caused the error:
if [ ! -f /local_code/onnv-gate/proto/root_i386/lib/libc_i18n.a -o \
! -f /local_code/onnv-gate/proto/root_i386/lib/amd64/libc_i18n.a ];
then \
if [ "$CLOSED_IS_PRESENT" = no ]; then \
echo "Warning: closed binaries not" \
"properly unpacked." >&2;\
echo "Missing libc_i18n.a" >&2; \
exit 1; \
else \
echo "Warning: libc_i18n.a must be built" \
"before libc can be built." >&2; \
exit 1; \
fi \

I use the latest closed bins and I created 3 times my build environment
with the same effect.
I also can't find any bugs related to "libc_i18n.a".

Piotr Jasiukajtis | estibi | SCA OS0072
on-discuss mailing list

Search Discussions

Discussion Posts


Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 3 of 4 | next ›
Discussion Overview
grouposunix-dev @
postedDec 11, '08 at 5:11p
activeDec 11, '08 at 11:04p



site design / logo © 2018 Grokbase