FAQ
From: "Ash Berlin" <ash_cpan@firemirror.com>
On 2 May 2009, at 09:25, Octavian R??ni?? wrote:

Hi,

I've started to use fastcgi with Apache and after a little fight with it,
I made it work, but I can't access /server-status anymore.

I've checked and mod_status.so is loaded in httpd.conf:

LoadModule status_module modules/mod_status.so

and it is also configured to show the server status on /server- status for
everyone:

<Location /server-status>
SetHandler server-status
Order deny,allow
Allow from all
</Location>

But when I access /server-status the Catalyst app gives the following
error:

Unknown resource server-status

(or Unknown resource server-status/ if I add a slash at the end)

I couldn't find anything about this issue anywhere.

Do you have any idea what could be the problem?

I use Apache 2.2.9, Perl 5.10.0 and the latest version of Catalyst under
Fedora.

Octavian
I'm guessing you've got your cat app rooted/deployed on '/' and are using
FastGCI (from your other thread)?
If so then I think you need something like this in the config:
Alias /server-status /server-status
Yes, this was the problem. I made some tests and I came to the conclusion
that Catalyst responds to all those URIs which don't have a distinct Alias
when it is used with fastcgi, no matter if they are handled by other
modules.

Octavian

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 3 of 5 | next ›
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedMay 2, '09 at 8:25a
activeMay 5, '09 at 10:45a
posts5
users4
websitecatalystframework.org
irc#catalyst

People

Translate

site design / logo © 2022 Grokbase