FAQ

Chisel Wright wrote:
On Tue, Jul 11, 2006 at 10:51:15AM +0100, Chisel Wright wrote:

Do I have a corrupt install after upgrading, or is this a bug?
OK, I've tried this on:

Ubuntu, upgraded catalyst
Gentoo, upgraded catalyst
Ubuntu, totally fresh install, fresh catalyst

All three fail to locate the ::Model::Class object method running under
the Catalyst server/test scripts.

Is anyone else using 5.7 and models with extra user-defined functions?

I'm just surprised that this seems to be happening everywhere for me,
and no-one else seems to have any problem.


Does anyone have 5-10 minutes to try the test(s) I outlined in my
previous message?

Chisel
I haven't actually run your test since I don't have Pg installed.

A few things tho:

1) You should really think about converting to DBIC::Schema instead.
2) What version were you upgrading from?
3) Did you also upgrade anything else?

And the key thing here:

4) You probably want some_method to be a method on the result_set: i.e.
something like the following:
http://search.cpan.org/~jrobinson/DBIx-Class-0.06003/lib/DBIx/Class/ResultSetManager.pm

Ash

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 6 of 17 | next ›
Discussion Overview
groupcatalyst @
categoriescatalyst, perl
postedJul 10, '06 at 1:42p
activeJul 18, '06 at 10:27a
posts17
users7
websitecatalystframework.org
irc#catalyst

People

Translate

site design / logo © 2022 Grokbase