FAQ
Finally i have managed to install 'Python' and 'Python-pip' from rpms from EPEL repository.


That good BUT:


root at secure [~]# pip install pymysql
Downloading/unpacking pymysql
Downloading PyMySQL-0.6.1.tar.gz (51kB): 51kB downloaded
Running setup.py egg_info for package pymysql
Installing collected packages: pymysql
Running setup.py install for pymysql
Successfully installed pymysql
Cleaning up...
root at secure [~]# pip install pygeoip
Downloading/unpacking pygeoip
Downloading pygeoip-0.3.0.tar.gz (97kB): 97kB downloaded
Running setup.py egg_info for package pygeoip
Installing collected packages: pygeoip
Running setup.py install for pygeoip
Successfully installed pygeoip
Cleaning up...
root at secure [~]#
root at secure [~]# pip list py*
distribute (0.6.10)
ethtool (0.6)
iniparse (0.3.1)
iwlib (1.0)
pycurl (7.19.0)
pygeoip (0.3.0)
pygpgme (0.1)
PyMySQL (0.6.1)
urlgrabber (3.9.1)
yum-metadata-parser (1.1.2)
root at secure [~]#


but when is: http://superhost.gr
i get the error you will like 'pymysql' and 'pymysql' are missing
Since they are install how can they be missing?


root at secure [~]# which python
/usr/bin/python


root at secure [~]# which python3
/usr/bin/python3
root at secure [~]#


The only thing i can think of is that those packages have installed under default python 2.6.6 and not under Python 3.3.2.


Can this be the case here?
And if yes then, how will i e those 2 packages with latest python?

Search Discussions

Discussion Posts

Follow ups

Related Discussions

People

Translate

site design / logo © 2022 Grokbase