FAQ

On Thu, 31 Mar 2011, Mark Sapiro wrote:

This error is due to one of several known incompatibilities between
Mailman versions older than 2.1.12 and Python 2.6 or later. See the
FAQ at <http://wiki.list.org/x/pYA9>.
I read the FAQ, which was however last updated in 2009.

This MIGHT not be a problem, because I'm running tests (as a sort of power
user) on my machine (suse 11.3 installed last december), but this is NOT
the target system. I'm pretty sure the target system will have suse 11.4
which came out recently.

suse 11.3 bundles mailman 2.1.11-13.2 and python 2.6.5-2.11 (however they
provide separately mailman 2.1.14-21.1 and python 2.7-43.1)

suse 11.4 bundles mailman 2.1.14-4.7.1 and python 2.7-8.2 (and provides
also 2.7-43.1)

I am really confused by all these minor subsubversions.

Is the suse 11.4 mm/python coupling sound ?
If so I will tell our sysadm to proceed, and pass on my test experience.
I might do a few further tests on my machine and occasionally report
problems here (be free to reply "usual 2.1.11/2.6 incompatibility").

Eventually I could upgrade mailman on my test machine (but not python)
if that is likely to work (just to test also the upgrade procedure).
If suse is packaging Mailman 2.1.11 with the Python 2.6.5 that you are
apparently using, this is a serious suse packaging problem.
I could report a bug, however if their 11.4 packaging is sound, they are
likely to consider it irrelevant.

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 2 | next ›
Discussion Overview
groupmailman-users @
categoriespython
postedApr 1, '11 at 7:57a
activeApr 1, '11 at 3:30p
posts2
users2
websitelist.org

2 users in discussion

Lucio Chiappetti: 1 post Mark Sapiro: 1 post

People

Translate

site design / logo © 2022 Grokbase