FAQ

marcos gonzalez wrote:
Im a administrator that mounted a mailman list inside my mail server, and I
discovered and strange problem with a list. My urls are good but not for all
lists, If I go to the pending request page, when I mark "submit al data"
button the url link redirects to a bad domain. To understand me:

http://mail.domain.com/cgi-bin/mailman/admindb/list

and checking I pass to

http://domain.com/cgi-bin/mailman/admindb/list

Anyone had similar problem? How I can repair ?
Put the following in mm_cfg.py

DEFAULT_URL_HOST = 'mail.domain.com' (or whatever the web domain is)
DEFAULT_EMAIL_HOST = 'domain.com' (or whatever the email domain is)
VIRTUAL_HOSTS.clear() (optional to remove Defaults.py
add_virtualhost())
add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)

Then run Mailman's

bin/withlist -l -a -r fix_url

Search the FAQ at
<http://wiki.list.org/display/DOC/Frequently+Asked+Questions> for
"fix_url" to see much more.

Note that if the bad lists were created with

bin/newlist LIST at domain.com

this is wrong. This notation is deprecated and counterintuitive and
should not be used. See

bin/newlist --help


--
Mark Sapiro <mark at msapiro.net> The highway is for gamblers,
San Francisco Bay Area, California better use your sense - B. Dylan

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 2 | next ›
Discussion Overview
groupmailman-users @
categoriespython
postedAug 30, '10 at 12:32p
activeAug 30, '10 at 8:22p
posts2
users2
websitelist.org

2 users in discussion

Mark Sapiro: 1 post Marcos gonzalez: 1 post

People

Translate

site design / logo © 2022 Grokbase