FAQ

Lennart Svensson wrote:
I got the following error (or warning):

/var/lib/mailman/Mailman/Handlers/Scrubber.py:175: DeprecationWarning: get_type() deprecated; use get_content_type()
ctype = part.get_type(part.get_default_type())


Using Mailman from Ubuntu distrubityion

Mailman version 2.1.5
Python 2.4.3 (#2, Oct 6 2006, 07:52:30)

A normal Mailman 2.1.5 installation incudes a pythonlib/ directory
which in turn contains the email 2.5.5 Python email package. The cron/
and bin/ directories contain a paths.py module which is imported by
the various scripts in those directories and which sets sys.path so
that the email package used is the one in pythonlib/.

The above warning indicates that something is missing from the above
scenario and you are getting the email 3.0.1 package from the Python
2.4.3 installation.

--
Mark Sapiro <msapiro at value.net> The highway is for gamblers,
San Francisco Bay Area, California better use your sense - B. Dylan

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 2 | next ›
Discussion Overview
groupmailman-users @
categoriespython
postedOct 16, '06 at 10:38p
activeOct 16, '06 at 10:55p
posts2
users2
websitelist.org

2 users in discussion

Lennart Svensson: 1 post Mark Sapiro: 1 post

People

Translate

site design / logo © 2022 Grokbase