FAQ
I have a virtual server at some provider.

They have an how-to to install and run mailman.

The OS is freebsd.

Some days ago, my consultant installed mailman, following their how-to
directions.

Version 2.1.7, the latest available.

When we started and tested mailman, it worked right, so we transfered
our lists from another server.

Then a problem arose, mailman got stuck. My consultant went to see the
log and noticed several *interrupted system calls*.

We thought it was due to a limitation of mailman in virtual environments.

As a workaround we put a script to restart mailman every 5 minuts.

All went smooth for a few days until last friday, when mailman got stuck
again and restarting it did not solve the problem.

My consultants watched the logs more carefully and they reported several
"interrupted system calls".

After a couple of days, mailman started to run again (we guess it was
due to the cron script) and released all the previous mail.

Incoming mail is always received regularly, no user receive errors and
it is always immediately put into the on line archive of the lists, it
just do not get delivered untile mailman starts delivering again...

Do you know of any problem relating to running mailman in virtual
environment? Any other hint? Unfortunately, log files are too concise to
get a good idea of what the problem is related to...

Thank you.


wiren

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 3 | next ›
Discussion Overview
groupmailman-users @
categoriespython
postedMay 3, '06 at 8:00a
activeMay 3, '06 at 3:16p
posts3
users3
websitelist.org

People

Translate

site design / logo © 2022 Grokbase