FAQ
I was doing some edits of the archive template files on my installation of
Mailman 2.1.5

Long story short, I ran into some write permission problems when trying to
upload my edited versions and in a fit of bone-headedness, I screwed up a
bunch of permissions by over zealously using the -R option of chmod...

This broke everything. I couldn't access the admin pages, the archives or
post to my lists. I panicked.

Then I tried to do a rebuild/reinstall from source. No luck there, and then
I remembered the check_perms script and used that to fix the damage I did.
After a restart of the mailman daemon using mailmanctl, I could now post to
the list and get to the admin pages.

So far so good. It's not a complete disaster anymore, just a minor one.

But now the archive simply will not work. Nothing gets added to the archive
mbox file when I post to the list nor can I access the archive web pages
(and yes, I double-checked the list archive settings and made sure the
archive files are all still there). I am using the built-in archiver, it
seems to not be able to find the archive files because all I get when I try
to view the archive is a page that says "Private archive file not found".

I've looked at everything I can think of at this point and can't find a
solution. What am I missing? Is there an obscure setting somewhere or a
database file or something out there that needs to be told what lists are
on the server?

Help will be much appreciated.

Dragon

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Venimus, Saltavimus, Bibimus (et naribus canium capti sumus)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 2 | next ›
Discussion Overview
groupmailman-users @
categoriespython
postedFeb 24, '06 at 11:46p
activeFeb 25, '06 at 1:22a
posts2
users2
websitelist.org

2 users in discussion

Dragon: 1 post Mark Sapiro: 1 post

People

Translate

site design / logo © 2022 Grokbase