With postgres 6.5.2 if noticed a dependency on __alpha__ being required
for Digital Unix/Compaq Tru64 UNIX.

The cc compiler only sets __alpha.
I found that adding -D__alpha__ to the alpha_cc template seemed to fix
the compile problems.

With 6.5.1, only __alpha was used by the #ifdefs (which is correct)

found in:
backend/utils/adt/float.c
include/storage/s_lock.h:

Personally, I thing __alpha__ should be changed back to __alpha__, but
adding -D__alpha__ to the alpha__cc template works.

Tested on Compaq Tru64 v4.0d using cc.

regards,
Dave Hill

--
+---------------------oOO--(_)--OOo------------------------+
Dave Hill (0 0) Unix Software Group |
Mailstop: ZKO3-2/W17 \//\/ |
Digital Equipment Corp. (603 )884-2985 |
110 Spitbrook Road /\//\ enet: ddhill@zk3.dec.com|
Nashua, NH 03062-2698 (0_0) |
+---------------------oOO--(_)--OOo------------------------+

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 1 | next ›
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedOct 11, '99 at 5:55p
activeOct 11, '99 at 5:55p
posts1
users1
websitepostgresql.org
irc#postgresql

1 user in discussion

Dave Hill: 1 post

People

Translate

site design / logo © 2022 Grokbase