FAQ

On Tue, Jul 1, 2008 at 7:50 PM, Tom Lane wrote:
"Randall Lucas" <rlucas@tercent.com> writes:
I dug in a bit more. It turns out that the Apple process of
transferring my data over from my old box transferred my
Fink-installed UNIX apps, including PostgreSQL 8.1.
And the contents of /sw/bin, no doubt?
Yes. Although, I'd been doing UNIX-y things for the past couple weeks
and nothing seemed broken, which makes this problem more pernicious.
Given that we've never heard the like from anyone else, I think that
(1) accusations against the upstream gawk maintainers seem misplaced,
Naturally; my incredulity at the brokenness of gawk didn't come
through, I guess ;)
I believe the most likely theory is that your copy of /sw/bin/awk
got corrupted during the transfer from your old machine, and the
second most likely theory is that the executable is bitwise the same
but it doesn't play nice with the system libraries on your new box,
and the third is that there was something wrong with that specific
Fink-port build (though if so, it should have failed on your old
machine too). In any case it sounds like a very local problem.
I like this last theory best. It is somewhat surprising to me that
more folks haven't hollered about it, given the ubiquity (?) of
upgrades to 10.5 from people who had installed Fink on 10.4.

I will try compiling 8.3.3 (and testing gawk) on my old 10.4 Intel Mac
which was the source of the gawk binary. I'll also report if the
binary is bitwise identical. No reply solicited for that; I just want
to keep it all in the same thread for archival / search engine
purposes.

Thanks again,

Randall

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 7 of 9 | next ›
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedJun 27, '08 at 11:25p
activeJul 5, '08 at 2:56a
posts9
users3
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase