I've asked on the Fedora Forums and the postgres IRC channel but haven't
received any feedback. I'm guessing there's just a library I'm missing
and I've tried this in 8.1.x, 8.2.6 and now 8.3.0 with the same result
so at least that's consistent. But when I do a './configure
--enable-thread-safety', it eventually bombs out saying:

...
checking for sgmlspl... sgmlspl
checking thread safety of required library functions... no
configure: error: thread test program failed
This platform is not thread-safe. Check the file 'config.log'for the
exact reason.

Upon checking the config.log, it says:
#define MEMSET_LOOP_LIMIT 1024
/* end confdefs.h. */
#include "./src/test/thread/thread_test.c"
configure:22450: result: no
configure:22459: error: thread test program failed
This platform is not thread-safe. Check the file 'config.log'for the
exact reason.

Google searches show some posts where there have been instances where
thread_test.c doesn't actually exist but this isn't the case here. This
completes successfully on an old and obsolete FC4 system so I think it's
just that I'm missing a particular safe thread library or something.
Can anyone point me in the right direction?

Thanks!

Carlos

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 4 | next ›
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedFeb 6, '08 at 4:52p
activeFeb 6, '08 at 6:18p
posts4
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

Carlos Picazzo: 2 posts Tom Lane: 2 posts

People

Translate

site design / logo © 2022 Grokbase