FAQ

gleykam@web.de wrote:

Hi,

trying to compile a thread-safe version of PostgreSQL 8.0.3 on IRIX
6.5 with standard C compiler cc there were errors running configure.

Viewing the config.log file, the test program is tried to be linked
with "-lpthreads". There is no such library on my system.
Strange. config.log tests all possible flags and uses only those that
actually compile safely. Can you send me that file offlist.
Using the configure option LIBS="-lpthread" everything is OK and the
binaries are created.

In the end 3 of 96 regression tests failed (float4, float8, geometry),
but in my optionion these have nothing to do with threads?
Irix doesn't get tons of testing. Try without threads and see if you
still get those, and email us the diffs from regression.diff.

--
Bruce Momjian | http://candle.pha.pa.us
pgman@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 2 | next ›
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedAug 16, '05 at 3:17p
activeAug 19, '05 at 1:28p
posts2
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

Gleykam: 1 post Bruce Momjian: 1 post

People

Translate

site design / logo © 2021 Grokbase