FAQ

Tatsuo Ishii wrote:
Here is a patch to fix the endian problem of 6.1. With this patch,
your big endian postgres server will begin to speak little endian as
6.0!
I have tested this patch on my Linux/i686/little-endian machine with
v6.1 and it does not damage my already working installation.

Tatsuo I. reports successful tests on several platforms. I vaguely
recall that someone else reported success on a mixed-endian pair of
platforms. Is there any reason to not introduce it into the source tree?

If no one expresses reservations in the next couple of days, and if no
one claims the job, I will go ahead and commit this to the source tree
as a candidate change for the upcoming jumbo-patch.

- Tom

btw, I used the patch which was re-posted by Tatsuo a couple of days ago
and which included as new patch for postgres.h as well as the original
patch for pqcomprim.c
Let's put it in so people can start testing the beta for 6.1p1.

- --
Bruce Momjian
maillist@candle.pha.pa.us

------------------------------

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 13 of 13 | next ›
Discussion Overview
grouppgsql-hackers @
categoriespostgresql
postedJun 18, '97 at 1:19a
activeJun 25, '97 at 3:29p
posts13
users7
websitepostgresql.org...
irc#postgresql

People

Translate

site design / logo © 2021 Grokbase