FAQ

On Thu, Jun 9, 2011 at 2:59 AM, Bhavin Kamani wrote:
I am installing postgresql using homebrew on OSX. I am getting strange
compilation errors. Googling did not help me in getting any lead to the
resolution. When I compile it on a standalone basis (without using brew) I
still get the same error. Compiling 9.1beta1 source package also gave me the
same set of errors.
Any lead/help will be highly appreciated.
I'm not exactly sure what's going on here, but contrib modules can be
built in two ways: with PGXS, or without PGXS. Typically, you compile
without PGXS when you're building the server and it's contrib modules,
and with PGXS if the server is already installed (and thus pg_config
is present) and you just want to compile one more module. Here it
looks like you're doing an in-tree compile but somehow PGXS is getting
enabled anyway - not sure what's going on there.

--
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 3 | next ›
Discussion Overview
grouppgsql-hackers @
categoriespostgresql
postedJun 9, '11 at 7:00a
activeJun 13, '11 at 4:25p
posts3
users2
websitepostgresql.org...
irc#postgresql

2 users in discussion

Bhavin Kamani: 2 posts Robert Haas: 1 post

People

Translate

site design / logo © 2021 Grokbase