Hi all,
I'm trying to build the rpms for RH9,
I downloaded the srpm for RH9 but I'm stuck on these errors:

Attempt a:

# rpmbuild --rebuild postgresql-8.0.7-1PGDG.src.rpm
Installing postgresql-8.0.7-1PGDG.src.rpm
error: Failed build dependencies:
tcl-devel is needed by postgresql-8.0.7-1PGDG

why tcl-devel on rh9 version? tcl-devel doesn't exist on rh9 )

Attempt b:
# rpmbuild --nodeps --rebuild postgresql-8.0.7-1PGDG.src.rpm
....
checking krb5.h presence... no
checking for krb5.h... no
configure: error: header file <krb5.h> is required for Kerberos 5
error: Bad exit status from /var/tmp/rpm-tmp.73067 (%build)


ok no kerberos now:

Attempt c:
# rpmbuild --nodeps --rebuild --define 'kerberos 0' postgresql-8.0.7-1PGDG.src.rpm
.....
checking for zlib.h... yes
checking openssl/ssl.h usability... no
checking openssl/ssl.h presence... no
checking for openssl/ssl.h... no
configure: error: header file <openssl/ssl.h> is required for OpenSSL
error: Bad exit status from /var/tmp/rpm-tmp.3109 (%build)

actually I have that file:

# locate openssl/ssl.h
/usr/include/openssl/ssl.h


Can someone help me in this ?


Regards
Gaetano Mendola

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 3 | next ›
Discussion Overview
grouppgsql-hackers @
categoriespostgresql
postedApr 11, '06 at 4:37p
activeApr 12, '06 at 10:20a
posts3
users3
websitepostgresql.org...
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase