Grokbase Groups Pig dev June 2011
FAQ
[ https://issues.apache.org/jira/browse/PIG-2148?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13058803#comment-13058803 ]

Alan Gates commented on PIG-2148:
---------------------------------

I'm fine with figuring out how we move to the default version not being a fat jar. I suspect we'll need to continue the fatjar for backward compatibility. But I'm not sure how long until we'll make this change. I'll leave this patch up for those who want to patch their existing systems in the meantime.
pig script should have command line option to use pig-withouthadoop.jar instead of pig-core.jar
-----------------------------------------------------------------------------------------------

Key: PIG-2148
URL: https://issues.apache.org/jira/browse/PIG-2148
Project: Pig
Issue Type: New Feature
Components: impl
Affects Versions: 0.9.0
Reporter: Alan Gates
Assignee: Alan Gates
Priority: Minor
Attachments: PIG-2148.patch


If you use Pig downloaded from Apache with Hadoop 0.20.203 or CDH3, you have to use the pig-withouthadoop.jar instead of pig-core.jar. However bin/pig uses pig-core.jar, meaning you can't use the shell script to start Pig. We need to add a -without option to bin/pig so that it will pick up the pig-withouthadoop.jar.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 7 of 7 | next ›
Discussion Overview
groupdev @
categoriespig, hadoop
postedJun 28, '11 at 10:07p
activeJul 1, '11 at 9:13p
posts7
users1
websitepig.apache.org

1 user in discussion

Alan Gates (JIRA): 7 posts

People

Translate

site design / logo © 2022 Grokbase