FAQ

On Tue, Jan 19, 2016 at 9:51 PM, Toby Hart Dyke wrote:
The Windows version of PHP doesn't quite work like that. All you should need
to do is load the extension. Have you uncommented these lines (removed the
semi-colon)?:

;extension=php_pgsql.dll
;extension=php_pdo_pgsql.dll

Once you've done that, restart Apache and you should be good to go.

Toby
On 17/01/2016 01:03, Peter Gostelow wrote:

Hi,

I installed an 'EnterpriseDB-ApachePHP' binary package that included
apache
2.2, postgresql 9.2, and php 5.4. That was years ago. I now want to
upgrade
to to php 5.5 and higher. I have installed apache 2.4, postgresql 9.3, and
php 5.5. They work fine.

The problem is that the php I downloaded from windows.php.net was not
configured with pdo postgres. I cannot use VC11 to compile my own php
because it doesn't work with vista system. Google hasn't turned up any php
binaries with pg enabled and it seems EnterpriseDB have dropped their
support for apache/php.

Either I am missing something, should switch to gnu/linux, or beg someone
to
build a binary with pg support.

Any suggestions?
Also if you use fastcgi, the VC versions do not have to match between
PHP and Apache.


--
Pierre

@pierrejoye | http://www.libgd.org

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 4 of 9 | next ›
Discussion Overview
groupphp-windows @
categoriesphp
postedJan 19, '16 at 1:23p
activeFeb 7, '16 at 6:26a
posts9
users5
websitephp.net

People

Translate

site design / logo © 2019 Grokbase