FAQ
Hi Julien and Ferenc,
On May 23, 2014, at 06:58, Julien Pauli wrote:

That's a no-go for 5.5.
5.5 is stable, 1year old (at this email date), and we should not
change such a thing into this stable branch.

For 5.6, we are actually in RC stage (with first RC to come soon).
Seeing the comments saying that it's all compatible and tests have
passed, I'm not against requiring bison 3.x for PHP 5.6.
Waiting for Ferenc's answer ;-)

Thank you for your patch and your support to make PHP better.
For your convenience, I’ve made a pull request for these changes against master (which would likely prevent at least one merge conflict vs. merging the 5.5-based pull request into master):

https://github.com/php/php-src/pull/685

I would point out that both pull requests only add Bison 3.x support; they don’t prevent Bison 2.x from working, so unless you have another reason for wanting to remove Bison 2.x support, this change doesn’t require dropping it. (I wouldn’t necessarily advocate dropping Bison 2.x support since we’re not actually using any Bison 3-specific features.).

Julien Pauli
-John

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 9 of 26 | next ›
Discussion Overview
groupphp-internals @
categoriesphp
postedMay 23, '14 at 1:02a
activeMay 29, '14 at 6:12p
posts26
users12
websitephp.net

People

Translate

site design / logo © 2022 Grokbase