FAQ
1) did you try to hook into your extension with debugger?
2) is your extension open-source (I mean: can you show the actual source-code?)
3) do you develop your extension with both zts and debug modes enabled?

On 8/16/07, BuildSmart wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I wrote an extension/module (quite some time ago) for PHP4, for the
last year or so (on and off) I've been rewriting it for PHP5.

Under PHP4 it works properly as an embedded extension or a loadable
module.

Under PHP5 it only appears to work properly as an embedded extension
but when it's a loadable module it fails to work properly.

What I mean by 'fails to work' properly is that it doesn't perform
the tasks it's supposed to perform.

I realize that this is not very explanatory and I really don't know
how else to explain it.

Since I don't know what the problem is or where to begin I was hoping
I could find some kind soul with a little time could assist me in
resolving this problem.

- -- Dale


--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

--
Alexey Zakhlestin
http://blog.milkfarmsoft.com/

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 3 | next ›
Discussion Overview
groupphp-internals @
categoriesphp
postedAug 16, '07 at 1:39p
activeAug 18, '07 at 6:37p
posts3
users2
websitephp.net

2 users in discussion

BuildSmart: 2 posts Alexey Zakhlestin: 1 post

People

Translate

site design / logo © 2022 Grokbase