FAQ
Edit report at https://bugs.php.net/bug.php?id=67910&edit=1

  ID: 67910
  Updated by: sixd@php.net
  Reported by: sixd@php.net
  Summary: PHP7 'make install' fails due to incomplete version
                      number changes in SAPIs
  Status: Open
  Type: Bug
  Package: Compile Failure
  Operating System: OS X
  PHP Version: master-Git-2014-08-26 (Git)
  Block user comment: N
  Private report: N

  New Comment:

See http://git.php.net/?p=php-src.git;a=commit;h=88099a0a27b8c95cf665f6c932672d2b25d305c4


Previous Comments:
------------------------------------------------------------------------
[2014-08-26 15:42:57] sixd@php.net

Description:
------------
Various references to php5 in sapi/*/* need updating to php7.

Currently installing into Apache 2 fails on OS X. The build successfully creates libs/libphp7.so but 'make install' looks for libphp5.so so it fails with the error:

Installing PHP SAPI module: apache2handler
/Users/cjones/opt/apache24/build/instdso.sh SH_LIBTOOL='/Users/cjones/opt/apache24/build/libtool' libs/libphp5.so /Users/cjones/opt/apache24/modules
/Users/cjones/opt/apache24/build/libtool --mode=install install libs/libphp5.so /Users/cjones/opt/apache24/modules/
libtool: install: install libs/libphp5.so /Users/cjones/opt/apache24/modules/libphp5.so
install: libs/libphp5.so: No such file or directory
apxs:Error: Command failed with rc=4653056
.
make: *** [install-sapi] Error 1




------------------------------------------------------------------------

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 4 | next ›
Discussion Overview
groupphp-bugs @
categoriesphp
postedAug 26, '14 at 3:43p
activeSep 20, '14 at 6:15p
posts4
users2
websitephp.net

2 users in discussion

Sixd: 3 posts Sixd: 1 post

People

Translate

site design / logo © 2019 Grokbase