FAQ
ID: 49975
Updated by: sniper@php.net
Reported By: e dot ehritt at web dot de
-Status: Open
+Status: Bogus
Bug Type: *General Issues
PHP Version: 5.3.1RC2
New Comment:

Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same.

Thank you for your interest in PHP.

See bug #48597


Previous Comments:
------------------------------------------------------------------------

[2009-10-23 17:27:37] e dot ehritt at web dot de

Description:
------------
It occurs in all current versions
Incoming request data are malformed:


POST / HTTP/1.1
Host: localhost
Content-Type: application/x-www-form-urlencoded
Content-Length: 17

a%5Bb%5Bc%5D%5D=d


Reproduce code:
---------------
<form action="s.php" method="post">
<p>
<input name="a[b[c]]" type="text"/>
<input type="submit">
</p>
</form>
#####################################################
<?php
# s.php
$a=array('a'=>array('b[c]'=>'d'));
print_r($_POST);
print_r($a);
?>

Expected result:
----------------
Array
(
[a] => Array
(
[b[c]] => d
)

)
Array
(
[a] => Array
(
[b[c]] => d
)

)

Actual result:
--------------
Array
(
[a] => Array
(
[b[c] => d
)

)
Array
(
[a] => Array
(
[b[c]] => d
)

)

So, I miss "]" in POST data.


------------------------------------------------------------------------


--
Edit this bug report at http://bugs.php.net/?id=49975&edit=1

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 2 | next ›
Discussion Overview
groupphp-bugs @
categoriesphp
postedOct 23, '09 at 5:27p
activeOct 23, '09 at 8:46p
posts2
users2
websitephp.net

People

Translate

site design / logo © 2018 Grokbase