FAQ
ID: 15834
Updated by: tjw@webteam.net
Reported By: john.naughton@ipayx.com
Status: Open
Bug Type: Reproducible crash
Operating System: linux RH7.1
PHP Version: 4.1.2
New Comment:

The problem here is clearly Verisign's choice to
statically link to OpenSSL 0.9.5a. I've had the same
problem in the past and was able to get it working
by loading libphp4.so before libssl.so in httpd.conf.

I currently have php 4.1.2 working with libcurl, and
mod_ssl using libpfpro.so (L300).

I am not however able to get the same combination to work
with php 4.2.0 or the latest libpfpro.so (L304).

Again, this is a VeriSign problem, not a PHP problem. If
anyone knows how to get in contact with the PayFlowPro
people, please let them know of this incompatability.


Previous Comments:
------------------------------------------------------------------------

[2002-03-03 08:19:30] john.naughton@ipayx.com

Same error and message. Following are my configuration parameters - if
this helps. Thanks.

./configure --with-apache=/usr/local/apache_1.3.22.src
--prefix=/usr/local --enable-libgcc --enable-pic --enable-shared
--enable-inline-optimization --with-exec-dir=/usr/local --with-png
--with-zlib --enable-magic-quotes --enable-safe-mode --enable-sockets
--enable-sysvsem --enable-sysvshm --enable-track-vars --enable-yp
--enable-ftp --enable-wddx --with-mysql --with-xml --with-mcrypt
--with-jpeg --with-tiff
--with-pfpro=/usr/local/verisign/payflowpro/linux

------------------------------------------------------------------------

[2002-03-02 22:08:06] rasmus@php.net

This can happen when you link a library not compiled/linked with gcc
into an app that is, or vice versa. Try adding this switch to your PHP
./configure line:

--enable-libgcc

------------------------------------------------------------------------

[2002-03-02 11:43:02] john.naughton@ipayx.com

Here it is.

#0 0x400d528c in __umoddi3 ()
from /usr/local/verisign/payflowpro/linux/lib/libpfpro.so
No symbol table info available.
#1 0x400b7678 in PNVersion ()
from /usr/local/verisign/payflowpro/linux/lib/libpfpro.so
No symbol table info available.
Cannot access memory at address 0x3

------------------------------------------------------------------------

[2002-03-02 11:38:26] derick@php.net

Oops :)

Can you hit 'bt full' on the prompt after the crash and post the
results again?

regards,
derick

------------------------------------------------------------------------

[2002-03-02 11:36:56] john.naughton@ipayx.com

Following is the message. Thanks.

Program received signal SIGSEGV, Segmentation fault.
0x400d528c in __umoddi3 ()
from /usr/local/verisign/payflowpro/linux/lib/libpfpro.so

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/15834

--
Edit this bug report at http://bugs.php.net/?id=15834&edit=1

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 10 of 11 | next ›
Discussion Overview
groupphp-bugs @
categoriesphp
postedMar 2, '02 at 4:18p
activeApr 27, '02 at 2:37a
posts11
users5
websitephp.net

People

Translate

site design / logo © 2022 Grokbase