FAQ
Edit report at https://pear.php.net/bugs/bug.php?id=19150&edit=1

ID: 19150
Updated by: helgith@gmail.com
Reported By: cweiske at php dot net
Summary: downgrading does not work if dependencies need to be
downgraded
Status: Open
Type: Bug
Package: PEAR
Package Version: 1.9.4
PHP Version: Irrelevant
Roadmap Versions:
New Comment:

How would you propose that happening? This is a fairly large problem in
it self as the
whole system needs to be checked, e.g. if you downgrade PHPUnit to 3.5
and want
everything else to be downgraded then there can be no other package that
depends
specifically on any of the versions of the packages being downgraded.

That plus the fact that to downgrade you actually have to force a
downgrade which
bypasses a lot of checks and filters.

I am not sure I particularly consider this a bug but it is true tho that
PEAR is more of
a forward facing system and less inclined on downgrades.


Previous Comments:
------------------------------------------------------------------------

[2011-12-20 10:50:04] cweiske

Description:
------------
When upgrading from phpunit 3.5 to 3.6, things broke. Downgrading was
not possible because some dependencies did not match anymore. The deps
need also to be downgraded, but pear didn't do that.

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 1 | next ›
Discussion Overview
grouppear-bugs @
categoriesphp
postedDec 22, '11 at 8:56p
activeDec 22, '11 at 8:56p
posts1
users1
websitepear.php.net

1 user in discussion

Helgith: 1 post

People

Translate

site design / logo © 2021 Grokbase