FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=18639&edit=1

ID: 18639
Updated by: till@php.net
Reported By: till at php dot net
Summary: regression: installing xdebug fails most likely due
to another fix
Status: Closed
Type: Bug
Package: PEAR
Package Version: 1.9.3
PHP Version: 5.3.1
Assigned To: dufuz
Roadmap Versions:
New Comment:

Fix works for me.


Previous Comments:
------------------------------------------------------------------------

[2011-07-03 22:48:51] dufuz

-Status: Analyzed
+Status: Closed
-Assigned To:
+Assigned To: dufuz
This bug has been fixed in SVN.

If this was a documentation problem, the fix will appear on pear.php.net
by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should
be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.

I committed my version of the patch (a bit simpler). Can you try trunk?

------------------------------------------------------------------------

[2011-07-03 22:04:55] dufuz

The fix you are proposing does not fix the main problem but that's a
different bug
perhaps, it's a problem with v1 packages.

------------------------------------------------------------------------

[2011-07-03 21:55:28] dufuz

package-PEAR.xml is v1, use package2.xml when you are doing the testing.
They are
both kept up to date (for now), just safer.

I will look at your patch and see if I can use it. Thanks

------------------------------------------------------------------------

[2011-07-02 20:04:45] till

-Status: Open
+Status: Analyzed
Ok, I think I figured it out:

pear package package-PEAR.xml
pear install <the-created-package>

So btw, I have a patch which works. I can now install all extensions
again:
https://gist.github.com/1061465

Changelog:
- introduced $tempDir as a temporary variable
- compare the file's basename
- break the loop only when 'config.m4' was found
- slightly refactoring of that loop

I didn't want to commit it, but I can if you give me the go-ahead.

------------------------------------------------------------------------

[2011-07-02 19:39:59] till

I can install various extensions with the previous release, but not with
this. List of
failures include xdebug, apm, etc..

I do have a question about 'testing' patches.

How do you do it? Is there a way to run 'pear' from within the pear-core
directory? Or
how do you go about it?

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://pear.php.net/bugs/bug.php?id=18639

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 7 of 7 | next ›
Discussion Overview
grouppear-bugs @
categoriesphp
postedJul 2, '11 at 2:04a
activeJul 4, '11 at 12:43p
posts7
users2
websitepear.php.net

2 users in discussion

Helgith: 4 posts Till: 3 posts

People

Translate

site design / logo © 2021 Grokbase