FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=18639&edit=1

ID: 18639
Updated by: helgith@gmail.com
Reported By: till at php dot net
Summary: regression: installing xdebug fails most likely due
to another fix
Status: Analyzed
Type: Bug
Package: PEAR
Package Version: 1.9.3
PHP Version: 5.3.1
Roadmap Versions:
New Comment:

package-PEAR.xml is v1, use package2.xml when you are doing the testing.
They are
both kept up to date (for now), just safer.

I will look at your patch and see if I can use it. Thanks


Previous Comments:
------------------------------------------------------------------------

[2011-07-02 20:04:45] till

-Status: Open
+Status: Analyzed
Ok, I think I figured it out:

pear package package-PEAR.xml
pear install <the-created-package>

So btw, I have a patch which works. I can now install all extensions
again:
https://gist.github.com/1061465

Changelog:
- introduced $tempDir as a temporary variable
- compare the file's basename
- break the loop only when 'config.m4' was found
- slightly refactoring of that loop

I didn't want to commit it, but I can if you give me the go-ahead.

------------------------------------------------------------------------

[2011-07-02 19:39:59] till

I can install various extensions with the previous release, but not with
this. List of
failures include xdebug, apm, etc..

I do have a question about 'testing' patches.

How do you do it? Is there a way to run 'pear' from within the pear-core
directory? Or
how do you go about it?

------------------------------------------------------------------------

[2011-07-02 04:04:09] dufuz

That fix actually has nothing to do with it... I checked already.

Still haven't found the specific cause.

------------------------------------------------------------------------

[2011-06-30 19:34:54] till

Description:
------------
http://svn.php.net/viewvc/pear/pear-
core/trunk/PEAR/Builder.php?
r1=311616&r2=311615&pathrev=311616

Someone on #pear mentioned that this fixed something for
xhprof (their screwed up file layout), but now xdebug fails to
install.

Test script:
---------------
till@till-laptop:~/workspaces/Mail_Queue/trunk/tests$ sudo pear
upgrade-all
Will upgrade channel://pear.zfcampus.org/zf
Will upgrade channel://pecl.php.net/xdebug
geometria-lab/rediska dependency package "zfcampus/zf" downloaded
version 1.11.7 is not the recommended version 1, but may be compatible,
use --force to install
zfcampus/ZF cannot be installed, conflicts with installed packages
downloading xdebug-2.1.1.tgz ...
Starting to download xdebug-2.1.1.tgz (303,198 bytes)
............done: 303,198 bytes
66 source files, building
running: phpize
Cannot find config.m4.
Make sure that you run '/usr/bin/phpize' in the top level source
directory of the module

ERROR: `phpize' failed


Expected result:
----------------
No error.

Actual result:
--------------
Error.

------------------------------------------------------------------------

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 4 of 7 | next ›
Discussion Overview
grouppear-bugs @
categoriesphp
postedJul 2, '11 at 2:04a
activeJul 4, '11 at 12:43p
posts7
users2
websitepear.php.net

2 users in discussion

Helgith: 4 posts Till: 3 posts

People

Translate

site design / logo © 2021 Grokbase