FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=18119&edit=1

ID: 18119
Updated by: daniel.oconnor@gmail.com
Reported By: ken at kenhaynes dot com
Summary: Incorrect validation
-Status: Open
+Status: Duplicate
Type: Bug
Package: Validate_US
Operating System: XP Pro SP3
Package Version: 0.5.4
PHP Version: 5.3.3
Roadmap Versions:
New Comment:

-Status: Open
+Status: Duplicate



Previous Comments:
------------------------------------------------------------------------

[2010-12-16 06:37:05] kenhaynes

Description:
------------
Hi,

I have just downloaded and installed Validate_US. I have only been in
the US for 2 years and my SSN is returned as Invalid". I tried my wife's
SSN using the same format and it returned "Valid".

I believe this has to do with the later SSNs so I thought that I had
better draw this to your attention so that it can be caught before it is
released from beta and starts to affect people's scripts.

I have not given my SSN in the code example for security reasons, but
please let me know if I can be of further assistance.

Regards,
Ken.

Test script:
---------------
include_once 'Validate/us.php';

$validate = new Validate_US();

echo $validate->ssn("xxx-xx-xxxx") ? "Valid SSN<br />" : "Invalid SSN<br
/>";


Expected result:
----------------
"Valid SSN" should be displayed.

Actual result:
--------------
"Invalid SSN" is displayed.

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 1 | next ›
Discussion Overview
grouppear-bugs @
categoriesphp
postedDec 16, '10 at 9:14a
activeDec 16, '10 at 9:14a
posts1
users1
websitepear.php.net

1 user in discussion

Daniel Oconnor: 1 post

People

Translate

site design / logo © 2022 Grokbase