FAQ

On Fri, Feb 12, 2010 at 6:19 PM, Todd Rinaldo wrote:

It seems like EUMM and M::B would do well to ignore INSTALLDIRS if $] >= 5.011. Both installers could flip a warning message if they intend to ignore INSTALLDIRS with some sort of "notify the author/here's how you override me if you insist on installing into perl core directories" message.

As insane as this idea might sound initially, I'd like to hear p5p's take on the idea.
^^^^^^

There are so many ways that could go wrong.

It would make more sense to try to control that via CPAN(PLUS) and
have them explicitly provide correct INSTALLDIRS, overriding whatever
might be in the Makefile.PL/Build.PL.

Unfortunately: code freeze. So that will have to wait until 5.14
unless Jesse thinks this is a blocker and can get people (not
including me) to patch CPAN(PLUS).

-- David

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 6 of 6 | next ›
Discussion Overview
groupperl5-porters @
categoriesperl
postedFeb 12, '10 at 6:16p
activeFeb 14, '10 at 12:57a
posts6
users4
websiteperl.org

People

Translate

site design / logo © 2022 Grokbase