FAQ

John Peacock wrote:
Why is that considered suspicious? This line:

require 5.6.0;

_isn't_ portable. Or do you mean that you don't think that warning
should be thrown [by default].
$ perl5.00504 -e 'require 5.6.0'
Can't locate 5.60 in @INC (@INC contains:
/usr/local/lib/perl5/5.00504/i686-linux /usr/local/lib/perl5/5.00504
/usr/local/lib/perl5/site_perl/5.005/i686-linux
/usr/local/lib/perl5/site_perl/5.005 .) at -e line 1.

$ perl5.00504 -e 'require 5.006'
Perl 5.006 required--this is only version 5.00504, stopped at -e line 1.

$ bleadperl -we 'require 5.6.0'
v-string in use/require non-portable at -e line 1.

$ bleadperl -we 'no warnings "portable"; require 5.6.0'


John

--
John Peacock
Director of Information Research and Technology
Rowman & Littlefield Publishing Group
4501 Forbes Boulevard
Suite H
Lanham, MD 20706
301-459-3366 x.5010
fax 301-429-5748

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 4 of 14 | next ›
Discussion Overview
groupperl5-porters @
categoriesperl
postedJul 20, '07 at 3:13p
activeJul 24, '07 at 3:26p
posts14
users8
websiteperl.org

People

Translate

site design / logo © 2019 Grokbase