FAQ

Eric Wilhelm wrote:
The one detail I'd note is that some distros use dotted decimal
('perl' => '5.8.0') so M::B::Compat should convert that (5.008000) in
a 'require 5.XXXXXX' line for older versions of Perl.
Yep. I think there's some version.pm fu for that.
$vobj->numify() return the floating point equivalent for any version
object (like ->normal() returns the fully normalized double dotted form).

On a closely related topic, I'm just responding on p5p to Merijn, who
just noticed that under bleadperl, the following:

require 5.8.0;

now issues a "portable" warning (whereas as long as you were running
5.6.0 or better it would just suck it up). Hrrrummmf...

John

--
John Peacock
Director of Information Research and Technology
Rowman & Littlefield Publishing Group
4501 Forbes Boulevard
Suite H
Lanham, MD 20706
301-459-3366 x.5010
fax 301-429-5748

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 13 of 30 | next ›
Discussion Overview
groupmodule-build @
categoriesperl
postedJul 19, '07 at 4:05a
activeAug 1, '07 at 1:15a
posts30
users7
websitecpan.org...

People

Translate

site design / logo © 2019 Grokbase